[DISCUSSION] Linux on LattePanda

A place to talk about all the Operating Systems, Software & Hardware
Forum rules

- Posts are to be made in the relevant forum. Users are asked to read the forum descriptions before posting.

- Members should post in a way which is consistent with "normal writing". That is users should not post excessive numbers of emoticons, large, small or coloured text, etc. Similarly users should not SHOUT or use excessive punctuation (e.g. ! and ?) in topic titles or posts.

- Members should use an appropriate, descriptive subject when posting a new topic. Examples of bad subjects include; "Help me!", "I'm stuck!", "I've got an error!", etc. Examples of good subjects include; "Getting an TABLE FULL error upon login", "Cannot restore a backup".

- Members are asked to post in English only so that posts can be well received and properly monitored.

- Spam is not tolerated here under any circumstance. This includes offering hosting services (charged and free), installation services, solicitation etc. Recruiting members for your own projects (moderators, designers, professional MOD work, etc.) is not permitted and is also considered spam. Users posting spam will be warned and their post removed.

- Members should post in a way that is respectful of other users. Flaming or abusing users in any way will not be tolerated and will lead to a warning. Vulgar language and inappropriate material is not allowed and will be removed. We try to maintain a family friendly atmosphere whenever it is possible within the main subject matter of this community. Please keep this in mind when participating.

- Each user is allowed to create one account. If you would like to change your username, please contact us and, most likely, we can do it for you while you can keep all of your profile data, posts, and other content.

- If a user violates our guidelines and shows a disregard for them, our staff and our community, they run the risk of losing their account. We reserve the right to deactivate any account and to edit or remove any content without warning. These guidelines are subject to change at any time without notice.

Thank you for visiting LattePanda.com!
User avatar
Coco Xia
Posts: 75
Joined: Wed Aug 02, 2017 8:36 am

Mon Aug 14, 2017 8:50 am

jinlatt wrote:I have encountered the same problem while installing Lubuntu 16.04...
--> "Sorry, Ubuntu 16.04 has experienced an internal error.... Ubiquity crashed...."
lwt wrote:Does anyone successfully install Linux on a 2G/32GB version of Lattepanda ?

The only distribution of Linux I can install is Debian 9.0.0.

Ubuntu installation fails because of Ubiquity crash. And the text mode installation (alternate CD) is no more available in latest version of Ubuntu.
The 32 bit UEFI requires some modification on the installation files (add /efi/boot/bootia32.efi). And this does not always works.

In addition, GNOME and LXCE desktop do not work. Only XFCE.
Hi , I met the same problem like yours, have you solved it? :(

User avatar
Posts: 14
Joined: Mon Sep 11, 2017 6:10 pm

Sun Sep 17, 2017 7:35 pm


Do we can extract the forensic images like E01, Ad1 using FTK imager or any other tool in Linux. If any one know how to do that. Please suggest.

Any help would be appreciated, Thanks in advance


User avatar
Posts: 1
Joined: Fri Sep 22, 2017 9:17 pm

Sat Sep 23, 2017 9:55 am

Dear LP community,

I erased WINDOWS for installing UBUNTU

But now I installed UBUNTU on 64 PANDA, it isnt booting.

I get errors:

efi: requested map not found
esrt: ESRT is not in the memory map

So any instructions given by the admin, I cant apply.

Is there any assistance?

User avatar
Posts: 37
Joined: Fri May 19, 2017 9:56 pm

Wed Oct 25, 2017 3:48 pm

There are 20 pages here on this topic.
Whats the current state for Ubuntu 16.04 LTS ?
Can you install it on the any of the LattePanda boards successfully with support for all the hardware?
Or is this still a science experiment?

User avatar
Posts: 2
Joined: Mon Nov 06, 2017 7:54 am

Mon Nov 06, 2017 8:32 am

I recently bought mine (4/64GB version) to play around with it and install Mycroft "AI" on it. As for the Linux support i went with Kubuntu with 4.13 kernel. Installation and booting went without any problems (64bit UEFI + 64 bit system). Wireless also works out of the box for me. Some minor flakiness that seems to have gone away by itself.

What does not work for me out of the box:
* Bluetooth - i have not applied any patches from the official github debian image as i don't care so much about Bluetooth
* Audio - i have applied the fixes however i could not get it to work.

Audio has another issue that is not related to the Lattepanda. Apparently the new pulseaudio version has problems with HDMI audio and constantly crashes -> no audio at all. So i blacklisted it to prevent the kernel modules from loading. Now pulseaudio works for me and I have an active microphone input (at least the signal-meter is jumping around)

I have spent hours on getting the audio jack to work and I don't know what else to do. I patched, reconfigured, reinstalled and changed all the possible settings. I can not get it to work with my headphones.
If anyone has an idea about that I would be very glad.

HDMI Bug Info:
* https://bugs.freedesktop.org/show_bug.cgi?id=100488
* https://bbs.archlinux.org/viewtopic.php?id=135782

User avatar
Posts: 17
Joined: Fri Nov 10, 2017 10:58 am

Fri Nov 10, 2017 11:19 am

Ritmann wrote:
Tue Aug 08, 2017 10:30 am
Has there been no luck so far installing Lubuntu, XUbuntu or standard Ubuntu on the 2G/32GB Z8350 yet?

I have tried numerous times, with Etcher, Rufus and Unetbootin for making the images. Also I tried all three pieces of software with both Lubuntu, Xubuntu and Ubuntu (all version 16.04, also the beta-version linked on page 3 in this thread) without luck. I can find the boot device in the boot menu, but picking them will simply be ignored and it will continue to Windows a little more slowly than usual.
Yes, it's strange, BIOS doesn't switch boot source and always direct to Windows. You must edit Windows bootloader and redirect to .efi of Ubuntu. This procedure is detailed in http://www.dfrobot.com.cn/community/for ... &tid=27266. Also, I too tried different versions of Ubuntu, the best result with Lubuntu 16.04.1 (lubuntu-16.04.1-desktop-amd64.iso) on LP 4/64, it works fine. But Lubuntu 16.04.3, 17.04, 17.10 and Ubuntu 16.04.2 don't work at all.

User avatar
Posts: 2
Joined: Mon Nov 06, 2017 7:54 am

Sat Nov 11, 2017 3:43 pm

The problem with the other Lattepandas might be that (as stated in the FAQ) the EFI is 32 bit which is not well handled by many modern Linux distributions which AFAIK ship with EFI 64bit only. There is a medium post that goes a little into the details on how to still make it work (with Arch Linux). See this link:
https://medium.com/@emerino/archlinux-o ... a651b661fd

User avatar
Posts: 17
Joined: Fri Nov 10, 2017 10:58 am

Wed Nov 22, 2017 4:58 pm

Dear LattePanda Site Admin!
On p.15, Wed Mar 01, 2017 you've promised to work on Audio Out. How are the results of this work? Have you solved this problem, are you continuing this work or have abandoned? The problems with WiFi may be succesfully solved by inserting TP Link adapter into USB, for newbie it's more safe and simple than patching the kernel. Lubuntu 16.04.1 sees WiFi adapter immediately, gives the list of available networks and links without any question. But problem with Audio remains hot. Please tell us, may it be solved by inserting Bluetooth adapter into USB and using Bluetooth audio or patching internal LP Bluetooth? Is there any Linux distro, which provides Audio out of box?

User avatar
Coco Xia
Posts: 75
Joined: Wed Aug 02, 2017 8:36 am

Thu Nov 23, 2017 9:38 am

No WI-FI , no Ethernet, no Bluetooth. What can i do with Ubuntu 16.04.3. :cry:

User avatar
Posts: 9
Joined: Tue Feb 28, 2017 2:58 pm

Thu Nov 23, 2017 7:15 pm

Er, Coco Xia, what are you talking about?
  • WiFi works with a BIOS tweak and a settings file, please read this post: https://is.gd/lattepandalinuxwifi (shortened URL but it links right back to these forums)
  • Ethernet works right out the box with Ubuntu 16.04.3 LTS although the interface name is something like enx???????????? (where ? is the mac address)
BT I don't know. It sees hci0 but it won't allow me to bring it up.

Post Reply