Disabling MIPI display from BIOS not working

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 1
    Joined: Tue Jul 30, 2019 5:39 pm

    Tue Aug 06, 2019 12:01 pm

    I am trying to use Ubuntu on my LattePanda with only an HDMI display. I want to disable the MIPI display from the BIOS because it causes problems being the primary display when I cannot see it, in text mode, on the login screen, and other places. This is similar to the How to Disable Internal Display from BIOS thread, but I'm reposting this question because I tried the advice in that thread and it did not work for me. I tried setting "Force Lid Status" to "Off" but it had no effect. I also tried other settings but couldn't find any to disable the MIPI display or to even make the HDMI the primary. Per the instructions for installing Ubuntu on the LattePanda, I installed the 1.2 BIOS for Ubuntu. This is with the 4GB / 64 GB eMMC board. Any advice?

    User avatar
    Posts: 14
    Joined: Tue Jan 07, 2020 5:14 pm

    Mon Jan 13, 2020 8:05 pm

    with Xubuntu 18.04 i add kernel parameter: video=DSI-1:d

    now is finaly present only HDMI display, xrandr show:

    Code: Select all

    Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 8192 x 8192
    DSI-1 disconnected (normal left inverted right x axis y axis)
    DP-1 disconnected (normal left inverted right x axis y axis)
    HDMI-1 disconnected (normal left inverted right x axis y axis)
    DP-2 disconnected (normal left inverted right x axis y axis)
    HDMI-2 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
       1920x1200     59.95*+
       1920x1080     60.00  
       1600x1200     60.00  
       1680x1050     59.88  
       1280x1024     60.02  
       1280x960      60.00  
       1024x768      60.00  
       800x600       60.32  
       640x480       59.94  
       720x400       70.08
    Xubuntu 18.04 64bit @ LattePanda 2GB/4GB S70CR200-CC34E

    Post Reply