[DEFECTIVE] Lattepanda WI-FI

userHead Cryzantine 2016-07-21 15:47:41 8140 Views8 Replies
Hello!

I was one of those many who supported your product in Kickstarter. My backer number is 3,471. First of all, I want to say thank you, this little machine is quite a marvelous accomplishment. It rans Windows 10 very well ^^. My unit is LattePanda 4G/64GB version.

Problem is the Wi-Fi. It worked for about a day and then it stopped working. It seems to see some wireless networks time to time but refuses to connect to any of them. Signal strength is really low also. I ordered two different more powerful replacement antennas (ASUS 2,4Ghz / 5Ghz antenna and TP-Link TL-ANT2408C) to test if the provided antenna was the culprit (hopefully, and not the board itself). The new antennas did not help however, the signal is stronger but it still only works for a few moments and then stops working. There are no hardware errors in windows device manager that I could see, the Wi-Fi simply refuses to connect after it loses the connection. This happens with both my routers Zyxel VMG3326 and Asus RT-AC87U as well as with my Lumia 950 XL Wi-Fi hot spots. When the Wi-Fi has lost the connection the only way to get it work for a few moments is a cold boot of the board itself. I have tried installing the windows plenty of times but to no avail, it does not fix the issue. The Wi-Fi driver update was also a no go. The Ethernet connection works well though. I have tested the WI-FI both with Windows 10 stable (and Anniversary update) and the latest Insider Preview but the results are the same. My belief is that the embedded Wi-FI chip is damaged :/


Best Regards

Marko Vallo
Tampere/Finland