[RESOLVED] SerialDevice::FromIdAsync null

userHead JodoKaast 2016-08-30 08:55:19 3750 Views2 Replies
Using lattepanda 4G/64G, just got it a few days ago.

I'm trying to use Microsoft's Remote Wiring, following the tutorial on lattepanda.com/docs/ but I can't get the UsbSerial object to work.

Whenever I call "connection.begin(57600, SerialConfig.SERIAL_8N1);" I get an error message:

Exception thrown at 0x7509DAE8 in blink.exe: Microsoft C++ exception: Platform::Exception ^ at memory location 0x060FD590. HRESULT:0x8000FFFF Catastrophic failure
WinRT information: Unable to initialize the device. Did you forget your USB device capabilities in the manifest? SerialDevice::FromIdAsync returned null.

I have added the DeviceCapability in my Package.appxmanifest inside <Capabilities>:

Code: Select all

<DeviceCapability Name="serialcommunication"> <Device Id="any"> <Function Type="name:serialPort" /> </Device> </DeviceCapability> I also get the same message when trying to use Microsoft's "Windows Remote Arduino Experience" app from their store. Interestingly, in the list of "Devices Discovered", there are two entries. I've tried both, but neither work.
WindowsRemoteArduinoExperience.png WindowsRemoteArduinoExperience.png (36.37 KiB) Viewed 3520 times I've uploaded StandardFirmata onto the Arduino already. I noticed in the comments for StandardFirmata that some boards, like the Leonardo, need to use a slightly different initialization, and I've tried both. The default:

Code: Select all

Firmata.begin(57600); while (!Serial) { ; } and the changed:

Code: Select all

Serial1.begin(57600); while (!Serial1) { ; } Firmata.begin(Serial1);