[DEFECTIVE] 4G/64G won't boot, red light blinking, runs hot

userHead namchucks 2016-09-11 22:41:32 9785 Views11 Replies
Hi everyone,

Kickstarter Backer 4,429

Ever since receiving my 4GB/64GB Enhanced Version, I haven't been able to get a successful boot. I've tried the included LattePanda Power Supply as well as a 5V 2.5a raspberry pi powersupply with no success.

Powering on the unit, blue and red light blinks. Blue light will turn off after a few seconds but red light keeps blinking. Holding the power button for a few seconds the red light still blinks. Holding it longer and the unit will shut off.

Keeping the unit plugged in for a while causing the metal parts to be extremely hot.

I have tested it with the included 7" screen as well has an HDMI compatible computer monitor but nothing shows up. I'm going through the forum and looking for related issues and I've tried a few.

I've tried these:
- Trying to boot up the device with a windows 10 bootable usb. No luck.
- Just ordered a bios programmer. Will probably come in 3-4 weeks.

Hopefully it's just a corrupted bios and reflashing will fix. If not, I'd like to be able to RMA this.

If I've missed any other possible solutions, please let me know. Thanks!