com port for arduino

userHead starfire151 2016-09-16 00:40:37 8785 Views9 Replies
I've got my new Lattepanda running and tried one of the example Arduino examples (Blink.ino). I selected the Leonardo as the board and looked at the com ports available. The ports were com1 and com3. I selected com3 and attempted to compile and download the program. It compiled successfully but complained that the com port was unavailable. I looked in the com port listing again and found com4 now available. I selected com4 and tried to compile/download again. This time it was successful and the program ran, blinking the blue LED on the top on and off.

I exited the session and tried it again. I loaded and modified the Blink program by having it toggle every half second. When I tried to compile and download, again the compilation was successful but the download attempt failed. I looked at the com port selection and it was only com1 and com3 again. This time com4 did not appear in the list. I looked at the Hardware Device Manager and it only listed com1 and com3.

1. The previous blink program continues to run even after a reset on the board. How do you stop a running program?
2. How do you get the Arduino to recognize all the available com ports?

Thanks.