USB3 port + hub

userHead atomix1040 2017-03-06 07:32:03 5068 Views4 Replies
I can connect a pendrive to the USB3 port.
I can't connect any other devices (i tried a gigabit ethernet dongle)

The biggest problem is a usb hub, i wanted to connect some other USB3 devices but i can't connect anything via a hub. The OS sees the hub, though it detects it as a USB2.0 hub (i have 4 different ones the same problem occurs with all of them), once i plug some USB3 device into the hub, nothing happens no device gets dettected no plug in event occurs. I tried powered and non powered hubs. I can connect USB2.0 devices to the hub and those work, but not USB3 devices.

Also i was wondering about self powered USB devices, i saw that you wrote that the 5V power rail is the same for USB and the SOC (i noticed that i can power the board via the USB3 port, once i connected an external RAID array that has it's own power the board also came online). Will this be a problem if i connect self powered devices what will happen, two power sources will cause problems i think.

What EFI/BIOS settings can i look into to fix the HUB issue ?