Waveshare HDMI touchscreen compatibility

userHead alawrence 2017-03-28 04:09:06 2150 Views1 Replies
I bought this touchscreen: https://www.amazon.com/Waveshare-10-1in ... B01CU7VX5Q for use with a Raspberry Pi. I'm trying to replace the Raspberry Pi with the standard 32-bit LattePanda.

When I plug the touchscreen into my Windows 10 Pro 64-bit laptop it comes up immediately with a resolution of 1024x600.

When I plug it into the LattePanda the touchscreen finds no signal. The LattePanda works fine with my standard desktop monitors. If I do a hard reboot of the LattePanda the touchscreen does display the LattePanda splash screen at what appears to be the native resolution of 1024x600.

Does the LattePanda need drivers for this touchscreen? It comes up as Generic PNP Monitor on my laptop without prompting me for driver installation.

I disassembled the screen a bit and found that it uses a driver board similar to this one (same chipset and many other similarities): https://learn.adafruit.com/hdmi-ubergui ... iver-board

I downloaded and ran EventGhost on both my LattePanda and my laptop. When I plug in and remove the RTD2660H-based driver board from my laptop I get:

System.DeviceAttached [u'\\\\?\\DISPLAY#HYS4859#4&1177c581&0&UID50729728#{e6f07b5f-ee97-4a90-b076-33f57bf4eaa7}']
System.DeviceRemoved [u'\\\\?\\DISPLAY#HYS4859#4&1177c581&0&UID50729728#{e6f07b5f-ee97-4a90-b076-33f57bf4eaa7}']

When I do it on the LattePanda I get nothing.

I tried adjusting BIOS settings in case the on-board display was conflicting with this touchscreen. I disabled the Force Lid Open and changed the video port to HDMI rather than Auto. Still no luck. What's notable is that with the Force Lid Open set to Off the LattePanda won't boot with the touchscreen plugged in. If I plug in my full-fledged Dell monitor I can boot to BIOS and if I switch the HDMI cable over to the touchscreen at that point I can view BIOS fine. Once I go to boot Windows the touchscreen will lose signal.

Any ideas? Could it be an HDMI version compliance compatibility issue? Is the RTD2660H chip only partially compliant to standards? I realize that the touchscreen may be at fault and there may be no issue with the LattePanda.

What can I do to get this screen to work with my LattePanda?