[RESOLVED] Installing Windows when USB boot fails

userHead QuakeDragon 2017-06-20 06:23:48 34627 Views10 Replies
Here I document my trial-and-error methods for booting the Windows OS install when the BIOS boot order was getting ignored. Another alternative title might be How I managed to install Windows when I could not boot from any USB devices. (Tested USB DVD, USB Flash Drives).

This was a new device, freshly unpacked and booted up. I experienced issues starting Windows for the first time. "OS goes to "Just a moment" for a very long time. Then the sysprep cmd window launches, then nothing happens." This issue is identical to this reddit post and has been posted a few times on the LattePanda forum already.

I followed the LattePanda documentation on reinstalling Windows to create the bootable USB stick. I set the boot order in BIOS, but it still just kicked me back to the pre-installed windows.

So I tried a different USB stick (sometimes they can be fussy) but the results were the same.
It just refused to boot to USB! Always defaulting back to the pre-installed Windows.

Next I grabbed a windows 10 home DVD and plugged in my trusty USB 2.0 DVD burner. It has it's own power source, so I was sure there wouldn't be any power draw issues. I accessed the BIOS and set my boot order. To my dismay, the system still refused to boot to USB (Just loaded the pre-installed Windows again.)

Next I used Microsoft's media creation tool and created a Windows 10 32-bit bootable USB stick. (32-bit because I am working on the 2G/32G version of the LattePanda, I shouldn't need the 64-bit version... or so I thought. read on!)
While it was downloading I did other stuff to shake my frustrations. Once finished, I connected the newly imaged USB stick to a different, working PC. It booted to the windows setup as expected.

I plug the USB stick into the 'Panda, change bios boot order settings... and it goes right back to the pre-installed windows. Won't boot from the USB stick or the USB DVD.

Ok, so that won't work. I get into the Windows troubleshooting start menu and I select the option to restore my PC, don't keep any settings. I start this process.

Around 49%, I get hit with a brief power outage. Hmm... at least it wasn't firmware, right? I wait for a bit to make sure the power is stable again, then I start it up. That's when I am greeted by a not-so-nice message:
"The computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows, click 'OK' to restart the computer, and then restart the installation.".
Picture:

Image

I got this same mesage no matter how many times I tried to F8 or otherwise access any windows safe mode.

Great. So now my pre-installed image is shot and I can't get this thing to boot from any USB device.
I really didn't feel up to installing and configuring a PXE server just for a single Windows 10 install. So I kept on tinkering.. and while tinkering, I noticed an entry on the BIOS exit screen labeled "Launch EFI Shell from filesystem device".
Picture:

Image

I ran this and after a moment I was provided a command line to the EFI shell. Cool. Reading the screen I notice the mount points and read to figure out which is my USB device. In this case, fs1:
Picture:

Image

I mounted my USB device by typing fs1:
then I typed cd efi
then I typed cd boot
then I typed in bootia32.efi
I was immediately notified that the Image type IA32 is not supported by this x64 shell. so, Microsoft used the Itanium efi on the x86 version of Windows 10 home? That just doesn't make sense.
Picture:

Image

So, once again I used Microsoft's media creation tool and created a Windows 10 64-bit bootable USB stick.

Once the stick was ready, I launched EFI Shell from the BIOS. Ran these commands (again):

fs1:
cd efi
cd boot
bootx64.efi

Image

Success! The shell launched the Windows setup program from the USB device.
Because of the problems I was having, I decided to delete the hard disk partitions and reinstall windows on a clean 'unallocated space' emmc disk.

Image

Afterwards, on another computer I downloaded the drivers from the LattePanda GITHub repository and transferred via the same USB stick. Then I proceeded to install drivers for all the unknown devices in the device manager. (it was a pretty long list.)

I had neglected to remove the USB stick from the LattePanda when I rebooted to finish installing the first of the device drivers. To my surprise, the 'Panda booted from the USB stick. So after the clean OS install my LattePanda began properly booting from the USB devices.

I removed the USB stick, rebooted into Windows and continued with device driver installation. I've since then updated Windows and have let the device 'burn in' for a day. It seems to be working perfectly now.

I hope you find this post informative and helpful. Use these instructions at your own discretion.
2018-08-11 14:53:36
doanldshimoda wrote: ↑Fri Aug 03, 2018 4:21 pm I believe latte panda staff must resolve that problems. How is posible cannot install windows 10 on latte panda? I foloow the procedures ans UDB never boot. I get my board yesterday from lattepanda suplly. Is a shame. Seems like hacking stuff dont have sense to hack and you expect to work out of the box like araspberry pi or any other IOT board. Im very dissapointed.
Agree. To be honest, we will work out several solution from the RD team and manufacturing team to develop a higher standard to control the production quality for each batch of LattePanda production. It's still not that easy to deliver a compact powerful device. Raspberry Pi is great. But I think any new computer manufacturer will experience such a process. We have much more experience on this after running our biz for 2 years from zero.

Quality problems are much less than before for latest batch LattePanda production.
Feel free to let us know your suggestion. We can work out and deliver better products to all users.
userHeadPic LattePanda
2018-08-04 00:21:43 I believe latte panda staff must resolve that problems. How is posible cannot install windows 10 on latte panda? I foloow the procedures ans UDB never boot. I get my board yesterday from lattepanda suplly. Is a shame. Seems like hacking stuff dont have sense to hack and you expect to work out of the box like araspberry pi or any other IOT board. Im very dissapointed. userHeadPic doanldshimoda
2018-06-21 15:24:26 Thank you !!!!!!!!!!!!
Best article - respect!!!!!!!!!!!!!!!!!!!!!!
userHeadPic djgarry
2018-04-17 16:21:47 Hi Renato Rocha ,welcome to the forum. How's everything going?
Did you solve your problem?
userHeadPic LattePanda
2018-04-13 00:18:24 Thank you very much QuakeDragon!!
I was having similar problems after installing debian on my LattePanda (32Gb/2Gb).
The bios wouldn't boot from the usb even when I changed the boot priorities.
After running the Microsoft Media Creation tool on a usb stick I plugged it in the LP and it automatically booted properlly ready to re-install Windows.
I was struggling with this issue for 2 days until I found this post!
I'm kind of a newbie to these informatic problems but I was wondering, since your LP now boots properlly through an USB stick couldn't you just install
the LP Windows 10 version instead of installing all the drivers and extra packages one by one?
I don't really know if this solution really solves the Bios booting problem but will check it out soon.

Congrats on the post
userHeadPic Renato Rocha
2017-11-20 11:15:59 Thanks for your feedback! userHeadPic LattePanda
2017-11-19 15:15:53 1.use una USB 3.0 de 16GB
2.darle formato en otro latte 16kilobytes y "WINPE" como etiqueta
3.extraer con 7.zip luego de abrir comprimido
El directorio DF-JX-7-S70CR110_CC55D-001-E
De 5.85GB 206 archivos
4.no cambiarle nada.
5.colocarla en USB 3
5. Conectar un switching poder supply RS 15-5 Mean Well (MW) 3amp
6.cuando apague el led rojo usar botón encendido
7.cuando solicite un Exit quite la fuente.
8.disfrute su LattePanda
userHeadPic AjGalvisr
2017-08-04 18:06:18 Hi , thanks a billon. The tutorial is clearly enough , I have solved my problem by following it. Best wishes. userHeadPic Coco Xia
2017-06-30 22:25:23 Thank you the instructions were perfect and I have managed to reinstall the image. The other points I have found:
1. Getting to BIOS was an issue sometimes the ESC key works sometimes not – might be my keyboard I guess.
2. Power is certainly an issue, we ended up running it off a bench power supply to ensure sufficient power. I suspect 2A is borderline.
userHeadPic JDWT
2017-06-26 11:01:58 VERY clear and detail tutorial. Really appreciate your effort and we will share your tutorial to people who meet with the same problem! :)
Will be really helpful!
userHeadPic LattePanda