Problem with USB 3.0 (v1.1, Enhanced)

userHead bpx 2017-12-04 23:13:59 1479 Views2 Replies
Dear LattePanda Community,

Hope someone can help me with this...

Some background: I'm a computer engineer and I work for a startup on the field of medical devices. We're currently developing an specific prototype which rely on multiple embedded systems, those controlled with the help of .NET APIs. In other words, we are currently controlling the whole device using a generic Windows 10 computer with a C# program. In order to reduce the size of the device, I suggested for the company to use LattePanda's as a central controller (even more convenient because we can control everything with a touch screen as well).

The current challenge: the LattePanda should be able to receive image data from CMOS sensors connected to a USB 3.0 Awaiba NanoEye board.

The problem: it simply doesn't work. The drivers seem to be installed correctly and the device is turned on and recognized. But if I try to initiate the board, it simply doesn't work (like it doesn't respond). The proprietary error handling of the board is tricky and I cannot tell exactly the problem. What I can tell is that I would get exactly the same error if I try to initiate the board with any other computer while plugging it to a USB 3.0 Hub, instead to the computer port directly.
What could this problem be? Could it be that the port is not providing enough current (even though I'm not using any other relevant peripheral)? Is it a known issue and is there any kind of fix for it?

What I've tried so far: updating the drivers, reflashing to the lastest BIOS and reloading the Windows image.

My setup: enhanced board (4GB RAM/64-bit), ver 1.1 (CR110 Z8350), using same power supply provided in the Starter Kit (DFRobot). No extra peripherals besides a wireless keyboard dongle and HDMI monitor.

For any help, I am thankful.