How to Disable Internal Display from BIOS?

userHead xieyi 2017-12-09 19:55:38 13105 Views6 Replies
Although it is possible to set HDMI display as primary display from BIOS, the non-exist internal display causes a lot of trouble. Specifically, Ubuntu 17.10 sets internal display as primary display and it is not easy to switch to HDMI display without seeing the desktop content. Also, other Linux distributions like to automatically connect to internal display on boot. Since I don't have a display to connect to the board, how to permanently disable it from BIOS?
I'm using 4G version of Lattepanda.
2020-01-14 03:49:28 disabling in BIOS not work for me, only sollution i found, with GNU/Linux use, is add kernel parameter: video=DSI-1:d userHeadPic k3dAR
2019-01-27 01:47:25 I'm trying to get opensuse running on my latte panda 4g/64. I've updated the bios, installed opensuse, but when it boots, I am brought to a blank screen with only the use of a mouse pointer. The internal display seems to be the active desktop, but I only have a monitor hooked up through hdmi. I thought I would be able to disabled the internal display through the bios, by:

BIOS->"Chipset"->"North Bridge"->"IGD - LCD Control"->"Force Lid Status"->"Off" .

... as mentioned above, but with no luck. I have also tried to toggle:

BIOS->"Chipset"=>"North Bridge"->"Intel IGD Configuration"->"Primary Display".

Are there any other options that I can try?
userHeadPic jaypro
2018-10-10 19:38:51 @mahdi.khazaee, I think if you connect the HDMI display, you will be able to access the BIOS again and recovery the default setting.
Look forward to your update!
userHeadPic LattePanda
2018-10-05 23:53:30 urgent help needed please userHeadPic mahdi.khazaee
2018-10-05 00:22:15 Hello to all!
I accidentally saw above query and answer when I was surfing the web
then i decided to do this amazing thing...
it worked! Screen went full black,,,but unfortunately I don't know how to enable it again????
When I turn on my tablet, there is nothing on screen so that I can turn on the "Force Lid Status"
please help me
I am afraid my tablet is dead! ! help me friends....
userHeadPic mahdi.khazaee
2017-12-11 15:36:45 Hi, just try it.

BIOS->"Chipset"->"North Bridge"->"IGD - LCD Control"->"Force Lid Status"->"Off" .

Hope it is helpful! Anything new please update here.
userHeadPic LattePanda