Ethernet, USB3 and Intel Graphics Properites Failure

userHead AlexO 2018-03-14 18:52:11 2534 Views2 Replies
4Gb/64G, CR200, Z8350, Windows Home. (Powered using a short Sony USB cable to 5v bench power supply capable of 3A.)

I would like to use the LattePanda for a USB3.0 Camera Interface.

I received the Panda and out the box tried to have a look at the Intel Graphics Properties, the initializing splash screen displays then there is a little flicker in the task bar and the main windows never shows. I would like to be able to access this to disable any of the Intel power saving stuff, also noticed the Ethernet connection didn't seem to be present in the network adapters, so not a great start.

I tried installing v1.1 4G x64 image linked from the manual, this got the Ethernet connection back, but did not fix the Intel properties issue, I then realized copying files from my USB3.0 hard disk seemed to be very broken, after some reading I realized v1.2 fixes USB3.0 issues.
Installed v1.2 BIOS from GitHub, USB3 now works OK, Ethernet adapter is missing again!

I can not use WiFi in my application, why is the Ethernet missing in v1.2?

Is anyone else on this board able to open the Intel graphics properties?

Thanks