[Alpha] Issues with powering on & Arduino Leonardo

userHead Myamens 2018-11-13 12:53:35 1611 Views0 Replies
Hello all,

I just received my Latte Panda Alpha with Windows 10 preinstalled/activated yesterday.
Really awesome little beast with lot of potentials.

My topic here has two problems I want to ask for:

1- [Major] Problem with powering the board:
The board run nicely and smoothly at the beginning, however after I shut it down, removed the power, and plugged the power back (always using the original USB-C adapter provided with), the board LED lights won't turn on.

I searched the forum and found similar issues, I tried them and sometimes work, sometimes fails.
The major problem is I can never use such procedure for actual applications, neither for any personal projects.
I want to know if this problem can be fixed using future firmware upgrade, or is it a hardware issue?
Anyone else never faced this problem, or is it a problem with all Alpha boards?

2- [Minor] Problem with Arduino Leonardo:
I tried to upload a test arduino sketch to the builtin arduino Leonardo (Blink program), however the port vanished and then appeared in the device manager with yellow icon next to it.
I searched the forum here and found similar problems, however in reality non worked. Every time I click the Arduino Rest button, it vanishes then appears with the same icon. It never appears with COM port ID.
Is the arduino wrecked? How can I fix it?


Again, I really love this board, and I am planning to use it for serious projects in the future.