[open] reflashing the LattePanda Alpha 864 BIOS

userHead birger.schmidt 2019-01-02 02:01:03 4195 Views3 Replies
Hi, I have misconfigured the BIOS of my LattePanda Alpha 864 in a way, that HDMI is not working until the OS (linux and windows 10 in my case) is started.

So I found a thread "How to blind recover from no HDMI output after bios edit" and unfortunately the [ESC..., F3, Enter, F4, Enter] sequence does not work for me. I'm quite sure I get into the BIOS by pressing either ESC or DEL, because after doing that I can wait forever and nothing happens (otherwise it boots into linux/windows). When I press [F3, Enter, F4, Enter] it reboots as well as when I press [ctrl, alt, del].

I can only assume, that the reset has not worked regarding the display settings.

As an alternative I've already tried to do a BIOS reset from within linux:

Code: Select all

modprobe nvram dd if=/dev/zero of=/dev/nvram But that did not solve my problem.
The LattePanda Alpha still boots into linux and I am flying blind 'til the linux boot logo.

I tried the HARD RESET option as well with no visible result.
At first I was confused about how the Arduino reset button can be the one that is meant there, but as that and the power button are the only buttons on the board, I just tried with those.

Now I'd like to try the reflash the BIOS way and I already have the tools to do that for Windows from AMI. But I need the BIOS file to flash.
Unfortunately the BIOS file for the LattePanda Alpha 864 is missing on github https://github.com/LattePandaTeam/Latte ... 0-Software.

@LattePanda can you please update the repo with the needed BIOS files for LP Alpha 864?

Thanks in advance,
Birger