[RESOLVED] Restoring UEFI Partition

userHead philgaskin 2019-01-05 02:05:02 2549 Views2 Replies
I have a new LattePanda Alpha 864 which is amazing.
I recently added an M.2 NVMe SSD and cloned the internal eMMC partitions (to preserve the Windows license) to the new NVMe drive - everything worked well and I resized my new C Drive to use the bigger storage.
As a precaution I left the original eMMC partitions on the internal disk until I was happy everything was okay.
After a week of very happy use, I decided to delete the original internal disk partitions to reformat as an additional drive.
After this my LPA won't boot - I suspect even though it was using the new NVMe disk for windows, the UEFI partition was still linked to the original eMMC disk.
If I boot to the UEFI command line from the BIOS and type:

Code: Select all

fs1: ls I can see all my Windows files, but if I type:

Code: Select all

fs0: cd efi cd boot bootx64.efi It boots, but I just get the same "Windows needs repairing" message

Is there any way to update or repair the boot mechanism to use the correct windows partition? Alternatively, is there a way of reinstalling afresh to the NVMe disk? I tried the instructions on the OS page but I just get a message stating "the required device isn't connected or can't be accessed"

I tried a Windows repair but Windows cannot fix it!

Any help is gratefully received.

Phil Attachments IMG_9729.JPG IMG_9729.JPG (102.1 KiB) Viewed 2104 times IMG_9728.JPG IMG_9728.JPG (88.05 KiB) Viewed 2104 times