LP Bios Update Failed - Bricked?

userHead avidgamer 2019-01-16 01:43:20 2403 Views2 Replies
I own a LattePanda 4G+64GB.

Sticker says: CR110 - Z8350

As i've been running this as a domain controller, with Windows Server 2012, I decided, finally, to update the BIOS to enable the auto-power on, which would be very handy in case of power cuts... I instantly regret that decision.

I tried updating the BIOS using the methods provided with a USB stick using the following link:
https://github.com/LattePandaTeam/Latte ... %20version

All seemed well, it cracked on with it, seemed to succeed (all reported - done). However, it will now not fire up at all. Arduino blue light goes off after inserting power. Red LED flashes constantly roughly every 1 second. Power button non-responsive. Reset button makes red LED solid for a moment, then returns to 1 second flashing. There is no HDMI output.

Assuming the BIOS didnt take properly, I've also bought a CH341A programmer, and flashed the BIOS chip with each available BIOS for the LattePanda that i own, and had no success what-so-ever. The CH341A programmer is reporting success and verification with each attempt. Upon attempting to boot the LP again, still the same old red LED single 1 second flash.

Has anyone got any ideas of what to try next? There's no way I managed to break the CPU/Power management from a "simple" BIOS update provided by LP themselves, surely? I've tried different power cables, different HDMI cables, different displays. Kind of lost here.