[DEFECTIVE] ? LattePanda Alpha 864 will not power on - No LEDs

userHead psalg001 2019-06-01 04:16:19 3108 Views2 Replies
Hello,

I have a Lattepanda Alpha 864 with windows activated.

I received my Lattepanda Alpha late January early February and used it for about 2-3 days ans then it stopped working. I contacted technical support and they recommended getting a new power supply. I got one from amazon that had the required specs and it fixed the problem.

https://www.amazon.com/gp/product/B0719 ... UTF8&psc=1

I used it for about a weeks but had to put it aside as my job took too much of my time. A couple of days ago, I was finally able to get back to working with the Alpha but after 4-5 hours it randomly turned off and I have not been able to get it to start ever since.

The LED lights do not turn on at all. As this is similar to what happened before, I got another USB-C power adapter to try to get it to work but it would still not turn on (no LEDs).

I read online here in the LattePanda support forums that this was a known issue and that sometimes switching to the DC input instead of the USB-C would fix the problem or tat least get it to work again. (See https://www.lattepanda.com/topic-f20t20875.html ) When I tried that today, it still did not turn on.

What should I do? I don't think I am still in the RMA window, but since this is a known issue I am hoping that something can be done.