Fail to power on.

userHead Cyber_One 2019-06-19 09:28:26 4689 Views5 Replies
I have had my Alpha 864 with windows activated for around 7 months.
This has been a great little workhorse, however a little over three weeks ago, it just stopped.

I have a 1TB SSD connected to the M.2 M-Keys slot which for the last 2 months contained the windows 10 OS.
Typically I do not turn off the Alpha except in the case of a power failure.
The Alpha has also been installed in a case that allows the fan to provide cooling, allow access to the connectors on the board and prevent accidental shorts by other loose components on my desk.
The BIOS setting have not been altered in the last 2 months (When i changed the boot device) and the thermal control has been set to maintain the CPU at the lowest temperature.
It has been powered by the supplied USB-C PD.

Last week on returning home from work, I noted it was powered down, pressing the power button did not turn it back on.

Testing has the following results:
The USB-C power supply is delivering 14.9V @ 0.04A.
None of the LED's are turning on at all.
I connected 12.0V-DC from a regulated power supply instead of the USB-C and noted a 0.016 amp current draw. Still the Alpha will not turn on.

With the Alpha orientated to that the CPU is on top and the USB-C is to the left, I started testing voltages on the round pads near the USB-C port and 12V power connector
when powered from the USB-C the middle pad of a group of 3 on the left side of the EJ898H USB-C power controller has 3.3V present, the other two pad have nothing.
When powered from the 12V DC all three pads are at 0V.
On the right side there is a pad with 3.3V when powered from either the USB-C or the 12V DC.

The external power switch connection also does not turn on the Alpha and has 0.5V across the terminal when powered by either the 12V DC or the USB-C.

The RTC Battery is testing at 3.1V
The 3.3V connections near the RTC battery are at 0.58V and the 5V is at 0.00V

Under the microscope I cannot see any visible signs of damage.

I suspect a component failure in the power control circuit, but without a schematic I am unable to proceed with any further investigations.

I have tried various reset methods suggested in the forum including the holding down of the Arduino reset with the power on button both with and without power connected, and the removal and reinsertion of the RTC battery for up to 24 hours.
None of the suggested fixes have worked.

Up until now, I found the Alpha to be a remarkable powerful PC
for both development work as well as some gaming,
I however have an amount of development work stored on the EMMC and would really like to get that data back along with getting the Alpha back up and running.

Is there any chance of obtaining the schematics so I can continue to diagnose and hopefully fix my Alpha.
Once repaired, I am happy to forward details of what failed for future reference.

This email has been sent to techsupport@lattepanda.com, however at this stage there has been no reply after 2 weeks.
I really do need the information stored on the emmc so would like to track down and repair the failed component.
I am really missing the little Alpha, it is incredible just how useful it is.
For those doubting its power, I run 3 monitors on this unit and program FPGA's with, mostly because I can