[DEFECTIVE] Another Dead Latte Panda Alpha (no LEDs)

userHead philgaskin 2020-03-08 03:55:39 6444 Views4 Replies
I've been using my LPA successfully since backing on Kickstarter. However, a week ago, when I tried to power it on, it was completely dead. I tried changing the USB-C power supply and even made a 12v DC power connector as others advised, but I get absolutely nothing - No LEDs at all. Although I've been using it for over a year, it is just used as a small footprint PC runnning Windows10.

My board seems to be in perfect condition with no obviously failed components. I even removed the fan to see if anything was fried, but again nothing obvious.
When using USB-C power, I see 0.5v on the 3.3v pins, 0.7v on the 12v and 0 on the 5v. When I power by 12v DC, I see 12v on the 12v line, 0.5v on the 3.3v and 0v on the 5v.

I'm obviously out of warranty period, but really disappointed that it is dead - my original LattePanda is still going strong after many years. I have reviewed the many post from people who appear to have the same problem and tried all the suggestions without success. It does appear to me that there must be a design fault somewhere for so many to fail with this symptom. I'd welcome ang further suggestions and attach images to show the very good state of the circuit board. Attachments IMG_1420.jpg IMG_1420.jpg (3.64 MiB) Viewed 6114 times IMG_1419.jpg IMG_1419.jpg (3.09 MiB) Viewed 6114 times