Another UART issue ! SOLVED !

userHead TehnikaMaori 2020-05-16 02:52:11 1773 Views1 Replies
Hi everyone,

After reading and trying most of solutions available here and elsewhere, I'm stuck with serial communication. The board LattePanda 2/32 (Activated Win10 with all updates, latest .NET, latest Arduino IDE) is behaving quite strange with the serial port between CPU and Arduino (in my case COM5). I have another external ArduinoNANO connected to USB.
So in my app (developed in .NET) I detect three ports, COM1, COM5 and COM6. I have both NANO and onboard Leonardo programmed as simple serial echo and my app is periodically polling for response from Arduino. Everything works as expected from COM1 (Rx and Tx pins 5 and 7 are simply bridged for testing) and COM6, except when trying to get response from COM5.

Now strange thing is, that using TeraTerm or RealTerm I'm getting normal response also from COM5, with the same settings (in all of them HW handshaking is disabled - but anyway - enabling in various combinations has no effect).

I thought the problem is in my app, but further I tried also app "Simple Serial Port Monitor" with no response from COM5 only.

I wouldn't write here not being at the top of my patience level after two days of digging just this.

At the end, please do not suggest to use firmata, because I'm developing a SW, that will be used primarely in other platforms. I have choosen LattePanda because of onboard IO, so I don't need any external circuits to acquire some analog values.

Please help me with your experience - at the end I'm sure there is just a tiny catch, that I overlooked somewhere. I'm just hoping, I won't be forced to use that external NANO.

Thank you.