UPS monitoring via LattePanda USB port

userHead pj66300 2020-06-23 01:41:00 1625 Views3 Replies
I have a 2GB/32GB unit with a Windows 10 Pro licence installed and running. I wish to use the unit to monitor a UPS which is to support a managed 24 port switcher in a relatively inaccessible place (the 19" rack in my loft). The UPS, a PowerWalker VI500 unit , can be monitored by a downloadable application from the manufacturer, titled PowerWalker PoweManager. This application runs on a PC to which the UPS is attached via a cable between the USB ports on the PC and the UPS. This application works fine on a standard desk top PC in that it recognises the UPS and shows the real time operating parameters of the UPS (I tried it). However, when this application is installed on the LattePanda it does not recognise the UPS and therefore does not display the real time data from the UPS. The LattePanda does however recognise the connection to the UPS and beeps. It also appears to register the UPS as if it were a battery running the LattePanda, as if it were a portable PC. The UPS manufacturer cannot understand why the software does not run as expected on the LattePanda and can offer no solution as to the problem. I have tried connecting the UPS to both a USB 2 port and the USB 3 port, but as expected this makes no difference to the end result. There seems to be some difference between the behaviour of the LattePanda USB ports and those on a standard desktop PC. Does anybody have any thoughts as to why this might be so? My intention was to use Tight VNC App to log in to the LattePanda so that I could remotely monitor the UPS. I should say that I had no problem installing and running the App on my desktop and the LP.
Peter