Another dead Alpha?

userHead tpaakki 2020-09-16 13:36:44 1365 Views1 Replies
Hi,

I have an Alpha that was working perfectly that I was using as a bit of digital signage. Recently I came in and found the display blank.

When I tried to boot it, the red light would flash 14 times and the blue light would slowly flash. I tried hard resets, pulling the clock battery, wiggling the standard LPA power cable, crossing fingers, and all to no avail. It has yet to light up a display.

Am I correct that the default answer here is to go out and buy a BIOS programmer and reflash the BIOS!?

After reading the other posts in the forum I have a lot of outstanding questions:
Is the LED pattern an exact indicator of corrupted BIOS? It would seem that a flashing indicator that flashes a certain number of times on every boot attempt is trying to say something? Is there a doc anywhere?
Is this honestly expected (and accepted) behavior!? Does a booted and running device just randomly lose its BIOS? How is this not considered a major design flaw?
Can I do this via RMA? Is there any guarantee it won't happen again?

Thank you to everyone who has invested such detail in the reflash docs - Has anyone had to do it more than once?