[SOLVED] - Broadcom 802.11abgn Wireless SDIO Adapter - Error Code 10

userHead Delphium 2020-11-04 00:26:54 5591 Views0 Replies

Hello Lattepanda team,

I have 3x Lattepanda 4/64 version CR110 boards, 1 of which I am repurposing from running android to Windows 10 but cannot get the wifi adapter to work.
The Broadcom 802.11abgn Wireless SDIO Adapter is detected but shows error Code 10, and so is unable to start.


I have followed the instructions/documentation from here - https://docs.lattepanda.com/content/1st_edition/os/ on how to reinstall the OS, and also to obtain the Windows 10 and Enterprise LTSC images.

I choose to use the Windows 10 LTSC edition as I have a key for this and to avoid hardware/software conflicts with Windows as various updates are released (creators/fall/anniversary/etc) which are seen on the Windows 10 Home/Pro editions.

Installed on the Lattepanda now is the Lattepanda Windows 10 Enterprise LTSC 1809 ( https://bit.ly/EnterpriseOsForLP )
Upon install, I see the Arduino application is preinstalled with a shortcut on the desktop and that the Windows 'System' panel shows that Windows 10 Enterprise LTSC 1809 Build 17763.805 is installed.

I have downloaded the driver package from Github ( https://github.com/LattePandaTeam/Latte ... 0-Software ) and pointed windows to the LattePanda-Win10-Software-master\Drivers\4G64GB_Drivers\All-in-one Pack\MRD-64bit-Intel-Driver-Release\Drivers folder to find the appropriate drivers.

Although a driver is identified and installed, it does not seem to work.

I have tried a few different drivers for the wifi adapter as listed here.
5.93.104.5 (04/26/2015)
5.93.103.27 (02/01/2016)
5.93.102.19 (07/09/2015)
None of these worked.

This is freshly installed from the image provided (LTSC 1809), and without any further Windows updates installed at this time.


Please can someone from the Lattepanda team provide a link to the correct combination of OS image + driver package for a 4/64 CR110 Z8350 board?


I am avoiding windows 10 Home/Pro due to the various updates (creators, fall, anniversary) that have at some point along the line broken compatibility with the Broadcom wifi adapter (as has happened on one of my other LattePanda devices which now runs linux).

At this moment I would just like to restore the Lattepanda to a functional device with base Windows 10 OS image and drivers as per how it used to work.
Note, if I switch back to android/linux, the wifi works fine, so its not a hardware problem as it clearly works still.

Thank you.


UPDATE:
Wifi adapter now working again after much trial and error to find a working combination of OS and Broadcom driver. PandaDriver.png PandaDriver.png (38.55 KiB) Viewed 3543 times 
Using Lattepanda Win10 Enterprise LTSB Image from ( https://bit.ly/EnterpriseOsForLP ) as provided in the instructions ( https://docs.lattepanda.com/content/1st_edition/os/ ) pandaLTSB.png pandaLTSB.png (77.33 KiB) Viewed 3543 times 
From the Microsoft catalogue I found a number of drivers available - ( https://www.catalog.update.microsoft.co ... 26pid_4324
Here I was then able to download any drivers I did not have already, one by one I tested each and found that version 5.93.103.27 worked for my system, 

The download the cab files containing the correct drivers was located in '20890550_9602388292e9ed2979f087af2d5b4015054bae79.cab' which is obtained from the Microsoft catalogue site. pandadriverworking.png pandadriverworking.png (218.81 KiB) Viewed 3543 times 
Now to see if this same driver will work with the later build of Windows 10 Enterprise LTSC 1809...

UPDATE2: Yes this driver downloaded from Microsoft works with Windows 10 LTSC 1809.
pandaworking.png pandaworking.png (268.81 KiB) Viewed 3539 times