Unable to install win10 on the LP alpha

userHead TSF 2020-11-18 19:56:57 1809 Views3 Replies

Hi,
I received a "Lattepanda Alpha 800" 3 weeks ago and I'm trying to get it working without any success since then.


Premises:
- I always powered the board only by using the official LP power adapter and the USB type C port.
- The 3 USBs were always occupied by:
----The mouse,
----The keyboard and
----The bootable USB.
- The HDMI cable was always connected.
- I attached since the first start the 2 Wifi antennas to the LP board.
- I attached a fan to cool down a bit the nvme SSD to the power pins on the arduino side of the board (+5V and relative GND).
- The ssds used where always plugged on the M.2 M key connector.


My journey:
I made the first boot using Kali Linux Live, and everything worked fine,
so I ordered an ssd via Amazon choosing a "SAMSUNG V-NAND SSD 970evo Plus NVME M.2" of 250GB and
the Windows 10 Pro ESD key.

Once arrived, I prepared the USB drive following the instructions posted here: https://docs.lattepanda.com/content/alpha_edition/os/
downloaded this win10 image: https://www.dropbox.com/sh/d2d4xoe2nk7n ... -101-B.zip
The installation went well, but once I logged in the OS, I got a BSOD with the error defined as "DPC_WATCHDOG_VIOLATION". I rebooted many times the system without
seeing at least one time the desktop... so I concluded that the installation got corrupted in some way.

I formatted the ssd and tried again and again (maybe 8-9 times) to reinstall the OS, unsuccessfully.
I tried with 3 different USB keys with respectively:
---- Your recommended Windows 10 installation (the one in the docs),
---- Your recommended Ubuntu linux installation (again following the docs) and
---- A normal Windows 10 installation using their media creation tool to flash the USBs (https://www.microsoft.com/it-it/softwar ... /windows10). 
I changed the order by the which mouse, keyboard and the bootable USB key where connected to the USBs ports.
I plugged and unplugged the ethernet cable.
I even put an additional 5V fan to cool down the ssd.
I tried also to unplug keyboard and mouse when the installation was going on.
The installation failed always in the middle of the process without any consistency giving an error about data corruption or a "DPC_WATCHDOG_VIOLATION" BSOD.

So I reflashed the bios on the board following the given instructions in your docs.
Booted up Ubuntu Live, it refused to start 1 time but in the next try started fine.
Tried 2-3 more times to install Windows 10 without again any result.
I didn't want to think that the LP board could be the problem, so I decided that maybe the ssd was failing to work properly and I changed it for an other one of
the same model.

When the new ssd arrived, after having prepared your recommended Windows 10 installation again, I tried it... and it worked!
I was excited to see finally the desktop, until I realized that the toolbar was unresponsive and the WIN button didn't worked.
After about 15 seconds I got an other BSOD with the error defined as "CRITICAL_SERVICE_FAILED"...
I never saw the desktop again since then.

I left the LP board hidden somewhere for maybe 3 days since it was getting me mad.
When returned in myself I tried again and again with different USBs,
following your Windows 10 installation and the classic Windows 10 installation process.
The results were... very unconsistent. Now on I got only Windows BSODs.
Sometimes the installation processes ended up fine, but the installed OS was corrupted, so on the first start they gave me BSOD error.
Sometimes the installation processes halted during the installation at different percentages of completion giving me various BSOD error.
I tried maybe 6 times and these are the Windows 10 BSOD error messages I got:
"KERNEL_MODE_HEAP_CORRUPTION"
"MEMORY_MANAGEMENT"
"KERNEL_SECURITY_CHECK_FAILURE"
"PAGE_FAULT_IN_NONPAGED_AREA"
"DPC_WATCHDOG_VIOLATION"
"IRQL_NOT_LESS_OR_EQUAL"


I don't know what to do now to get it work properly and I don't think that a third SSD could solve the problems I got, so I'm open to try all your ideas.
I wanted to work on a project using this board and I wanted to order others in the future if the prototype would work fine.

Thank you in advance,
for the time you spent reading this long post and
for the help you'll give me.

TSF.