LEDs suggest LP has booted but no HDMI or USB (tried everything!)

userHead alicestewart 2021-02-08 20:47:38 1737 Views3 Replies
I have a Latte Panda Delta that was purchased about 2 months ago.

Have been using it with no issues until:
I installed an eGPU - ASUS GT710 (https://www.asus.com/Motherboards-Compo ... H-SL-2GD5/) in the M2 slot powered with a separate power supply, and everything was working smoothly with two HDMI screens - one from the LP HDMI output and the other from my GT710 HDMI output. I had installed the drivers for the GT710 on the LP.

I shut down the LP, I removed the eGPU and tried to restart as normal but the following issue started:

When I supply power to the LP, the red/blue lights blink a bit before the blue light blinks singling its ready to be turned on. I hold the on button and the blue light becomes consistent (this is what happens to the LEDs when the LP boots successfully). Then nothing happens… the onboard HDMI, audio jack and USBs are all disabled.

I’ve tried:
Using a USB C adapter for the HDMI output and powering the board through the onboard connector @ 12V 5A
Using a USB C adapter to power the board and use HDMI/USB inputs
Hard reset by holding for 20sec etc
Removing RTC battery
Adding a USB with the Win10 image on there, but I can't access it...

I can’t flash bios or even access them because the USB Keyboard is not working. No lights turn on my keyboard - nothing happens. I can’t see anything and the HDMI doesn’t even seem like its detecting anything.

Any help much appreciated! Thank you