Lattepanda Alpha 864 not powering trough USB-C but powering with 12V DC

userHead Obakemono 2021-03-12 05:55:58 3517 Views11 Replies
Hello,

I just got a Lattepanda Alpha 864 from a friend who didn't used it much (have been sittin in a drawer from some time now but the last time it was used it powered fine with the LPD included power adaptor).

When i tried to plug it for the first time i found out that it is frozen dead if i use the LPD included USB-C power adaptor (no power, no leds), i've been reading a lot about other people issues with the powering stuff and i managed to improvise powering it with a 12V DC holding the cables by hand as i didn't had the conectors to make the adapter (already ordered) and i got leds and was able to turn it on (i think at least, just tried to verify the board wasn't dead).

I have no other USB-C charger to test it with the LPD nor any other device i can try the included power adapter with so i'm not sure if the power adapter is dead or just stuck in some other power mode (is the one with a lot of modes to negotitate).

The thing is i'm not sure what can i expect:

I have read some people saying that once i power it with the 12V DC i might regain USB-C powering since it can be in some kind of limbo state and might get unstuck, is this really a thing?, like will it renegotiate with the power adapter again?

If that is a no no, it is supposed to work with one of the alternative power adapters recomended and be entirely a problem with the incluede adapter or i won't be able to power it with USB-C never ever again and it should try to RMA it? (i know that is consensus that the included power adapter is bad).

It is an older unit so it won't have any possible firmware/BIOS update in case it matters.

Sorry for the long post and ty