LattePanda Z8350 failing on boot

userHead Akorna 2021-12-07 05:33:51 941 Views1 Replies

I'm new to this, so I'm very sorry if this is a known thing, I tried to find it on fora, but couldn't find an answer.

I've managed to get my hands on a used LattePanda Z8350 2G/32GB. The previous owner installed Ubuntu on it so that's the setup I started with.

When powering the device, Ubuntu boots normally but as soon as the loginscreen appears the whole thing crashes down (peripherals lose their power, such as numlock on the keyboard etc.) and the only way to get it up again is maintaining the power button for 20 seconds, but the same thing will happen again.

Based on the doc (https://docs.lattepanda.com/content/1st_edition/os/), I followed all steps to install Ubuntu again, no change. I tried to restore BIOS settings to default in case the previous owner thinkered with stuff in there, but still the same thing.

I tried to install Windows 10 again (again as instructed in the official panda documentation), but when inserting the USB with Windows on it, I get an error message, more info: https://woshub.com/windows-8-winload-efi ... r-damaged/. But then same thing for Windows 10. But since I'm running a Ubuntu on it (since it's before the install process of Windows 10) I'm very amazed it's complaining about something that should be on the C:/ drive.

I'm a bit at a loss if there's anything left I could try to save the soul of this panda, is there any way to debug whatever is happening to it? Has anyone encountered this before and know a solution or in what direction to look for one?