[DEFECTIVE] LattePanda Alpha 864s - No HDMI signal output

userHead menelkiner 2019-12-26 16:21:53 3774 Views1 Replies

I recently picked up a LattePanda Alpha 864s that I use as a media server and for light desktop use.

The board has started to not output an HDMI signal for unknown reasons. I have not tried tinkering with the BIOS or any other settings. It was working perfectly, then one morning it just wasn't.

The board itself seems to act normally, red LED pulses when power is applied then goes solid with intermittent blue flashes. Pushing the power button seems to boot the device normally, the blue LED goes solid and stays on with the red LED. There is just no video signal coming out of the board.

I am using the supplied charger, and have tried other high-powered supplies with no effect.
No combination of cables or different monitors yields a positive result, I just get "no signal" or "check signal cable" warnings on the screens.

I have tried hard reset as outlined here:
https://www.lattepanda.com/forum/topic/312903

I have tried reinstalling the OS:
https://docs.lattepanda.com/content/alpha_edition/os/#operating-system

I have tried flashing the bios:
https://github.com/LattePandaTeam/Latte ... ha%26Delta

I have also tried removing the RTC battery then booting, with no effect.

I do not own or have access to an eDP display that uses the ribbon connector so check if HDMI out is the only issue.
I do not own or have access to hardware to try flashing the BIOS at a hardware level.

I am open to further suggestions to try and breathe life back into this SBC.
It was a perfect product for me and I was considering getting a second before this happened.
At this point, the only option I see is getting an RMA and hoping it can be fixed...