[DEFECTIVE] LattePanda startup issue / RMA request

userHead M100FAT 2020-01-06 10:38:59 3698 Views3 Replies
Dear Lattepanda support,

This post is regarding a LattePanda Alpha M3-7Y30, 8GBRAM

It has worked well before I flashed the bios.
It started with reflashing the bios to get auto power on working. Something must have gone wrong there since it did not want to start after the reflash.

The lattepanda would not boot anymore and when given power it wouldn’t even show any leds. I tried powercycling, flushing, the power+reset button fix, but no results.

Now however I’ve been able to get to the bios through a USB bios programmer and install the default bios again. Odd thing is it still didn’t work. Nothing, not even a red light when powered. And yes I have tried the powerbutton + reset button combo many times.

I’ve searched some more and read somewhere that sometimes removing the RTC battery for a longer period of time could help. So I removed it, after about 1,5 – 2 hours I decided to try it again. At first nothing, but after a while the blue light came on (instead of the red) then the red, then it would act as if the powercable had a cable break somewhere (but this does not seem to be the case when testing with other pandas), flashing and dimming in a seemingly random way. Then it would stabilise on red. So I decided to push my luck and try to start, to my amazement it worked. It booted to windows no problem. Happy I shut it down and reïnstalled the RTC battery thinking everything was fixed. But after installing the RTC battery again it wouldn’t start just like before, no led. I felt like I was frustratingly close to getting it to work again, but I had no idea why or how.

I’ve tried letting it lie without RTC battery again, and this time I got a weak blue flash that dimmed and then nothing.

The next day still nothing, so I decided I would check again with the bios programmer, there was still data on the bios, but it didn’t match what it should be.
(yes I have checked the RTC battery and yes it gave the expected voltage)

After a lot of trying and reprogramming the bios with a bios programmer once again it randomly started up again, but this time I noticed I had my finger pressed to the back of the pcb, tried it again without finger, nothing, tried it again with finger and it worked again. Now when power stays connected I can shut it down, restart it, everything works. But if the power has been disconnected the first time I want to start it I have to press my finger to that spot.
When starting with my finger on the right spot (on the backside of where the power from the adaptor enters the PCB) it will start with flashing the red led, then after a while it will stabilize and the red led will stay on and the blue light flashes occasionally (like it normally would). Once the red led has stabilized I can remove my finger and start the lattepanda.

It would seem this issue starting it does not lie with the BIOS and is due to hardware failure, therefore I would like to start an RMA procedure.

Sincerely,

Maarten Huizing,

P.S. Thanks to the lattepanda team for reacting quickly to my email to have my account activated.