Auto boot on power options - Alpha 864s (Core i5-8210Y)

userHead LeonMcEniery 2022-09-13 10:26:22 222 Views3 Replies

Hello All,

 

Model: LattePanda Alpha 864s (DFR0546)

Processor: Intel Core i5-8210Y

OS: Ubuntu Server 20.04

 

I have read the previous threads regarding the updated BIOS that can be used to gain access to auto boot settings in the BIOS.

But as the updated version of the Alpha 864s has the i5-8210Y I don't believe the files in https://www.lattepanda.com/forum/topic/315077 will work.

 

Do you have an updated BIOS file for the new Alpha 864s that has the auto-boot on power functionality?

 

We are using the LattePanda Alpha for a tethered robotic system and required this for the system to start up correctly (without user intervention).

2022-09-20 14:58:18

Hi there,

 

pls refer to the link below for the auto power on file of your LattePanda Alpha.

https://github.com/LattePandaTeam/LattePanda-Win10-Software/tree/master/BIOS%20for%20LattePanda%20Alpha%26Delta/Alpha-8210y

(EC- auto power on)

userHeadPic Queena
LeonMcEniery wrote:

Thank you Queena,

This worked. The files in the github repo differed from the file names stated in the other guides, but it worked and the LattePanda now boots on power.

 

As reference to others reading this, I had already installed Ubuntu 20.04 OS.

 

I followed the following steps, please let me know if I have made any mistakes. Would you like me to push this as a Readme.md to the github repo?

 

1. On a separate computer, formatted a USB to "FAT32" format with the name "WINPE" (using windows formatter)

2. Downloaded the .zip folder "EC- Auto power on.zip" from the repo here-> https://github.com/LattePandaTeam/LattePanda-Win10-Software/tree/master/BIOS%20for%20LattePanda%20Alpha%26Delta/Alpha-8210y

3. Extracted the folder from the .zip

4. Copied all files from the downloaded folder onto the usb

5. Inserted USB into the LattePanda, and while booting the LattePanda pressed the "ESC" to enter the BIOS settings

6. Navigated to "Save & Exit", selected "UEFI: Build-in EFI Shell" and pressed "Enter"

7. Once the "Shell>" was shown, I input "fsX:" where "X" was 1 in my case as the usb was mounted at 1 (X could be 1,2,3…)

8. Typed the following "eFuitX64.efi /u S70KR310A-VC-poweron.bin" and pressed enter

9. The ITE Flash utility then showed up and I waited until it had finished successfully

10. Pressed "CTRL + ALT + DEL" to restart

11. I let the system boot fully, then I fully shutdown and removed the power

12. Upon plugging in power, the system boots!! Woohoo

2022-10-07 13:41:00
Queena wrote:

thank you for your kind proposal. very appreciated if you push this guide as a Readme.md to the github repo.

2022-10-09 17:28:05
2 Replies