No HDMI audio output - Fedora - Lattepanda 3 Delta

userHead tenu.kenol 2022-11-14 21:31:46 484 Views1 Replies


I just got my Lattepanda 3 Delta, a quite new single board pc, there isn't much about it online yet besides the official webpage.

It comes with Windows 10 preinstalled. On Windows everything works fine. I've tried installing Ubuntu on an SSD, and audio worked fine as well.

Now I've replaced Ubuntu with Fedora, and there's no audio output through HDMI whatsoever. The correct output audio device is selected, the preview sound bars show there should be sound coming out, yet I hear nothing.

Not sure if that matters, but my display is connected via USB-C to the Lattepanda, they both have a fully featured USB-C port and I'm using a fully featured USB-C cable (PD+DP+Data)

I'm trying to get a Linux distribution on it mostly because I'll want to run display+device on a portable powerbank and Windows is eating 1% battery per minute, I'm hoping Linux does slightly better (although it'll be a minimal difference, most of the power draw comes from the monitor itself, it's just an excuse to add some variety to my life, and I honestly had enough of Ubuntu years ago).