LP Sigma - "SIM Card Missing" when inserted

userHead NASA-JEWL 2024-03-16 04:33:40 235 Views1 Replies

I have a Telit FN990A40 5G Modem installed on my LP Sigma running Ubuntu 22.04. The modem is detected by the OS and can be interacted with via `mmcli`. 

 

I cannot get any SIM cards to be detected when inserted though (I have tried 4 different SIM cards from different SIM manufacturers). One possible issue may be that the documentation here states the notch must be facing outward when inserted. However, with a standard SIM card, the notch is always in the top-right when looking at the side with contacts. Due to this top-right orientation, it is impossible to insert with the notch facing outward, the release mechanism will not trigger when you insert the SIM with contacts correctly oriented face down (I have tried this anyways and it's still not detected). I've also tried what I would think is actually the correct orientation, documented here for the LP Delta 3rd edition. Notch facing in, pointing towards the upper left (see screenshot below), and the SIM isn't recognized. 

 

In fact, I've tried all 4 possible orientations with multiple SIM cards, none of them make any messages appear in `syslog` or `dmesg`, and `mmcli` never detects a SIM as inserted. I've also restarted ModemManager and reboot the system with the card inserted the entire time, no changes. How do I get the SIM card to be properly recognized by my OS and modem? Is there an additional step to it other than simply inserting it into the SBC's SIM card slot?

All the SIMs I've tried. None of these are detected, am I missing something simple?