Drivers for windows 8.1 pro

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:


    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Kano.net
    Posts: 3
    Joined: Fri Mar 24, 2017 4:12 pm

    Sun Mar 26, 2017 5:55 pm

    I installed windows 8.1 pro (32 bit) to my lattepanda 2/32 succesfully, but it is impossible to install drivers also.
    When I use setup.exe the installation does not run to finish and some failrue appears. When I use CMD, even like administrator, the installation is succesfull but a lot of files has comment: Number succesfully imported: 0.
    I tried to install the drivers manually, but none of them was succesfull. Everytime some error code appears (51 or 37 for example).
    Im starting to be hopeless. for my aplication I need windows 8.1, because the software I need to use is not compatible with win 10. But now audio, touch panel, card reader and also wifi does not work. Can anyone help me where is the mistake? Or it is necessary to find another drivers?

    User avatar
    LattePanda
    Site Admin
    Posts: 2641
    Joined: Wed Jan 20, 2016 9:09 am

    Tue Mar 28, 2017 3:49 am

    Hi there,

    We don't officially support Windows 8.1 so I can only provide you with Windows 10 drivers, but it seems like you have already tried everything. As you say, it seems as if it is necessary to find drivers from another source. I will investigate and see if I can find more information.
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Kano.net
    Posts: 3
    Joined: Fri Mar 24, 2017 4:12 pm

    Tue Mar 28, 2017 10:20 am

    Is it possible to know exact specifications of latte panda 2G/32G devices? You know, so I can find the drivers...

    User avatar
    LattePanda
    Site Admin
    Posts: 2641
    Joined: Wed Jan 20, 2016 9:09 am

    Tue Mar 28, 2017 10:27 am

    Kano.net wrote:Is it possible to know exact specifications of latte panda 2G/32G devices? You know, so I can find the drivers...
    what exactly do you need?
    you can use software such as belarc advisor to generate an audit of the hardware

    taken from here: https://www.dfrobot.com/product-1405.html

    Intel Cherry Trail Z8350 Quad Core Processor
    Base Frequency: 1.44GHz (1.92GHz Burst Frequency)
    Operating System: Windows 10 Home Edition
    RAM: 2GB DDR3L
    Storage Capacity: 32GB
    GPU: Intel HD Graphics, 12 EUs @200-500Mhz, single-channel memory
    USB 3.0 x 1, USB 2.0 x 2
    Wi-Fi 802.11n 2.4G
    Bluetooth 4.0
    Integrated Arduino Co-processor: ATmega32u4 (Arduino Leonardo)
    Video output: HDMI and MIPI-DSI
    Onboard touch panel overlay connector
    Supports 100Mbps Ethernet
    Intel Processor GPIO x 6
    ATmega Processor GPIO x 20
    Gravity Interface Connectors x 6
    Voltage: 5V@2A
    Board Dimensions: 88 x 70mm / 3.46 x 2.76"
    Package Dimensions: 110 x 94 x 30 mm/4.33 x 3.70 x 1.18"
    NET Weight: 55g
    Gross Weight: 100g
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Kano.net
    Posts: 3
    Joined: Fri Mar 24, 2017 4:12 pm

    Tue Mar 28, 2017 11:14 am

    Well it is easy. I need to find out wifi drivers, beacuse it doesnt work. How do I find the drivers for device with name Wi-Fi 802.11n 2.4G? I would like to hear for example REALTEK ... and so on. But for example, I downloaded Intel SST audio drivers, installation was succesfull, but the audio output still doesnt work because the device is forbidden. Well i have to do something wrong...

    Same with wifi, ethernet connection works normally, but I dont see any adapter and even no device in device manager...

    User avatar
    LattePanda
    Site Admin
    Posts: 2641
    Joined: Wed Jan 20, 2016 9:09 am

    Wed Mar 29, 2017 3:16 am

    The WiFi/Bluetooth module is a Realtek RTL8723BS
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    ender
    Posts: 129
    Joined: Wed Dec 27, 2017 3:55 pm

    Wed Mar 04, 2020 6:27 am

    what is the last situation
    Was it installed with Win 8.1 drivers?

    Post Reply