No bios firmware update for LP 4G/64G S70CR200-CC55G?

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:


    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    raidensnake
    Posts: 25
    Joined: Mon Apr 23, 2018 7:31 am

    Tue Nov 06, 2018 3:01 pm

    I just wanted to know what's going on with the firmware updates as my lattepanda keeps crashing due to a known bug in the older firmware. When I look on this GitHub page https://github.com/LattePandaTeam/Latte ... %20version It lists only the following:

    S70CR200 Z8350
    CC55D/CC55E -> DF-BI-7-S70CR200-CC55D-003-XX
    CC55F -> DF-BI-7-S70CR200-CC55F-022-XX

    But there's no mention of the S70CR200-CC55G Model anywhere.
    Are there any recommendations of what firmware to use or do I need to wait for a version to come out?

    User avatar
    LattePanda
    Site Admin
    Posts: 2688
    Joined: Wed Jan 20, 2016 9:09 am

    Wed Nov 21, 2018 9:34 pm

    I think we should have update the answer via github. But still response it here again that just go with CC55F, which is compatible for your model.
    Enjoy Tinkering with LattePanda ! :lol:

    Post Reply