[DEFECTIVE] RMA Process

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:


    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    thomasii
    Posts: 3
    Joined: Sun Dec 02, 2018 8:04 pm

    Tue Dec 11, 2018 11:25 pm

    Greetings All,

    Is anyone else having issues with the RMA procedure?

    Trying to follow the guidelines in the red box at the top of the page. I posted a issue marked it as defective over a week ago and have had no reply. I have also tried to send a private message and email, again no response.

    I'm curious how many of you have current issues without response from the LattePanda folks.

    User avatar
    guildjw
    Posts: 4
    Joined: Wed Jun 22, 2016 7:09 pm

    Wed May 29, 2019 2:59 pm

    My Alpha unit has blown one of the SMA components (one of four located at DC power input connector on negative side. Prior to that the USB-D PD failed. Unit is past 30 day purchase (Kickstarter). Are you offering repairs (at a reasonable cost or a discount on a replacement unit). Alpha was working fine, both from DC power and USB-C just noticed smell one day and when I looked there was visible component failure. If I can't get repair can I get the part and have it replaced locally here in the states? Thank you,


    John

    User avatar
    ccs_hello
    Posts: 394
    Joined: Sat Oct 13, 2018 9:16 pm

    Thu May 30, 2019 2:24 am

    Just a small note:
    It's a MagnaChip's N-ch MOSFET MDV3605.

    Post Reply