Arduino Com port has disappeared

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    User avatar
    Posts: 25
    Joined: Tue Sep 12, 2017 3:42 pm

    Wed Feb 14, 2018 8:50 pm

    We're using a case where it will be a sealed unit that the customer won't be expected to open it.

    I brought this up over in one of the other forums too, but no one seems to want to answer the question.

    Can the Arduino on the LattePanda be reset via software to solve this COM port issue? Or is there something else that can be done with a pin where we bring it high or low to reset the Arduino?

    User avatar
    Site Admin
    Posts: 2761
    Joined: Wed Jan 20, 2016 9:09 am

    Sat Feb 24, 2018 9:14 am

    I did some quick research. You need to set DTR and reopen the com port via a script or some specific software.

    And I find this python code for that purpose:

    My Python script to reset a Leonardo is like this:

    Code: Select all

    import serial
    import sys
    ser = serial.Serial()
    ser.port = sys.argv[1]
    ser.baudrate = 1200
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Posts: 2
    Joined: Wed Apr 11, 2018 3:28 pm

    Wed Apr 11, 2018 3:55 pm

    We are LattePanda newbies, trying to load the "blink" test to check out the methods and systems. We have Visual Studio 2017, and a 2Gb/32Gb board running Windows 10.

    When we try to upload a sketch such as Blink, not only does the port change, sometimes it disappears (greyed out) in the serial port setting in Arduino. We have read through the blogs, pressed reset, powered up and down, tried all of the sensible and useful things, and it still happens. Running the application throws an exception when VS can't find the port.

    Back in the bad old days when 100 lines of tested machine code was a good day's work, this kind of problem was expected, and a lot of people died because of it, which is why we went to the trouble of designing high level languages and decent operating systems, and most importantly, good documentation.

    As users, this is not our problem, it sits firmly with the manufacturer / supplier. It is a fundamental system bug, not finger trouble, and it shouldn't happen. So how's about somebody from LTP actually fixes it, instead of just reading the blogs? Our intended application is airborne, and we can't tolerate bugs like this. So before we toss the LattePanda into the bin (plus getting our money back) and switch to a conventional mini PC (pity, because the hardware format and the capability of running VB.Net (our main support language) is very attractive). We would be happy to help find the problem, but the documentation is so poor that we don't have enough platform info to even make a start.

    Thanks in anticipation ........

    User avatar
    Site Admin
    Posts: 2761
    Joined: Wed Jan 20, 2016 9:09 am

    Tue Apr 17, 2018 9:27 am

    Hey, how's everything going?
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Posts: 5
    Joined: Wed Nov 14, 2018 10:44 pm

    Sun Dec 02, 2018 12:29 pm

    Hey admin,
    I have still that problem like here discussed.
    How to solve that?

    Regards, Klaus

    Post Reply