How to fix the 1GB RAM bug on LattePanda 2GB/32GB

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Site Admin
    Posts: 2760
    Joined: Wed Jan 20, 2016 9:09 am

    Wed Mar 27, 2019 11:50 am

    Recently, we received some feedback from customers that they bought 2GB/32GB LattePanda 1st Gen boards, but the system shows 1GB RAM.
    The problem is because of CPU's bug and the production batch is August 2018, S/N:KBMP180808XXXXX. At present this problem has been solved already, and will not appear in the following batches.
    The possibility of this problem is very small, but If you have the same problem, please reflash the BIOS according to the tutorial below, so that your board can correctly identify the RAM.

    Step 1.Backup your product key
    Please download this tools to find the correct key pre-activated with the system, then copy and backup it.
    Product Key.png
    Product Key.png (81.17 KiB) Viewed 1901 times
    Step 2.Update the BIOS files
    Please download the BIOS file HERE.

    How to refresh the LattePanda BIOS:
    1. Format your U-disk to FAT32
    2. Copy the right BIOS files directly to root of the USB flash disk
    3. Plug the U-disk in USB host
    4. Plugin the MicroUSB cable and power on the system
    Warning: Do not unplug the U-disk when refreshing!

    5.Wait the refreshing the BIOS automatically until returning "FPT Operation Passed"
    6. Remove the U-disk!
    Note: Make sure that remove the U-disk before restarting the system!

    7. Restart the system via pressing the reset button or "Ctrl+Alt+Del".
    8. Wait the board restart.

    Step 3.Re-activate your LattePanda
    If you need to install the system after refreshing the bios, please use the product key you backed up in Step 1. to re-activate your LattePanda.
    Make sure your LattePanda has an active internet connection via Wi-Fi or Ethernet
    1. Right click on the Windows button and select “System”
    2. Click “Activate Windows”
    3. Click “Change Product Key”
    4. Enter the product key
    5. Click “Next”
    Enjoy Tinkering with LattePanda ! :lol:

    Post Reply