How to build Intel MediaSDK on ubuntu 16.04 in Lattepanda?

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    GIbeom Song
    Posts: 1
    Joined: Mon Apr 29, 2019 12:15 pm

    Mon Apr 29, 2019 12:30 pm

    Hello, I'm a beginner of Lattepanda and trying to make the Opencv based video playback in Lattepanda (4G/64GB) using Intel graphics acceleration because video playing without Intel graphics acceleration is very slow.

    To reach the goal, I followed this reference ... s-of-linux.
    Although I proceed "vainfo" command to confirm whether Intel media drier is installed correctly, the result is not good like below.

    Code: Select all

    libva info: VA-API version 0.99.0
    libva info: va_getDriverName() returns 0
    libva info: User requested driver 'iHD'
    libva info: Trying to open /opt/intel/mediasdk/lib64/
    libva info: Found init function __vaDriverInit_0_32
    libva info: va_openDriver() returns 0
    vainfo: VA-API version: 0.99 (libva 1.67.0.pre1)
    vainfo: Driver version:
    vainfo: Supported profile and entrypoints
          VAProfileH264ConstrainedBaseline:    VAEntrypointVLD
          VAProfileH264ConstrainedBaseline:    VAEntrypointEncSlice
          VAProfileH264ConstrainedBaseline:    <unknown entrypoint>
          VAProfileH264ConstrainedBaseline:    <unknown entrypoint>
          VAProfileH264Main               :    VAEntrypointVLD
          VAProfileH264Main               :    VAEntrypointEncSlice
          VAProfileH264Main               :    <unknown entrypoint>
          VAProfileH264Main               :    <unknown entrypoint>
          VAProfileH264High               :    VAEntrypointVLD
          VAProfileH264High               :    VAEntrypointEncSlice
          VAProfileH264High               :    <unknown entrypoint>
          VAProfileH264High               :    <unknown entrypoint>
          VAProfileMPEG2Simple            :    VAEntrypointEncSlice
          VAProfileMPEG2Simple            :    VAEntrypointVLD
          VAProfileMPEG2Main              :    VAEntrypointEncSlice
          VAProfileMPEG2Main              :    VAEntrypointVLD
          VAProfileVC1Advanced            :    VAEntrypointVLD
          VAProfileVC1Main                :    VAEntrypointVLD
          VAProfileVC1Simple              :    VAEntrypointVLD
          VAProfileJPEGBaseline           :    VAEntrypointVLD
          VAProfileJPEGBaseline           :    VAEntrypointEncPicture
          VAProfileVP8Version0_3          :    VAEntrypointEncSlice
          VAProfileVP8Version0_3          :    VAEntrypointVLD
          VAProfileVP8Version0_3          :    <unknown entrypoint>
          VAProfileVP9Profile0            :    <unknown entrypoint>
          <unknown profile>               :    VAEntrypointV[sup][/sup]ideoProc
          VAProfileNone                   :    VAEntrypointVideoProc
          VAProfileNone                   :    <unknown entrypoint>
    Segmentation fault (core dumped)
    Please teach me, How can I solve this problem?
    And then, using Intel graphics acceleration in ubuntu 16.04 is impossible?
    For reference, Ubuntu 16.04 was installed through LattePanda manual

    Post Reply