Arduino digital output does not work

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 2
    Joined: Sun Mar 08, 2020 2:25 am

    Fri Mar 13, 2020 4:52 am

    I'm using two LattePanda 4G/64GB with Windows10.
    One Arduino uses 1.8.10.
    Another Arduino uses 1.0.6. (original)

    I have a problem with Arduino digital output.
    Digital output does not respond even if the following code is executed.
    The operation is the same for both Lattepandas.

    void setup() {
    pinMode(7, OUTPUT);
    digitalWrite(7, LOW);

    void loop() {
    digitalWrite(7, HIGH);
    digitalWrite(7, LOW);

    Pin No.7(D7), 9(D9) are NG.
    but, Pin No.10(D10), No.13(D13) are OK.
    No.13's LED is blinking.

    am I forgetting any settings?

    User avatar
    Site Admin
    Posts: 2641
    Joined: Wed Jan 20, 2016 9:09 am

    Fri Mar 13, 2020 10:19 am

    Hi t157, do both your two LattePanda have the same issue? if only one of them can't work, pls contact our for help.
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Posts: 2
    Joined: Sun Mar 08, 2020 2:25 am

    Sat Mar 14, 2020 8:28 am

    That's right. Both are the same.

    Post Reply