5MP UVC Camera inconsistent FOV

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 1
    Joined: Tue Aug 18, 2020 9:06 am

    Tue Aug 18, 2020 9:11 am

    Hardware: LattePanda 5MP UVC Camera
    Android phone via OTG
    Software: Android/Google Play store: USB Camera - Connect EasyCap or USB WebCam
    (沈垚 / ShenYao China)

    The FOV in 1080p is noticeably less than all other resolutions, just wondering why this is? I purchased the camera under the belief that it this FOV would be consistent across all resolutions.


    User avatar
    Posts: 621
    Joined: Sat Oct 13, 2018 9:16 pm

    Wed Aug 19, 2020 12:30 am

    Per website desiption, the image sensor used is OV5640. On its datasheet, page 22, it has the following 6 supported format:

    5 Mpixel 2592x1944 15 fps
    full resolution

    1280x960 1280x960 45 fps
    subsampling in vertical and horizontal to 1296x968
    (supports 2x2 binning)

    1080p 1920x1080 30 fps cropping from full resolution

    720p 1280x720 60 fps
    cropping 2592x1944 to 2560x1440
    subsampling in vertical and horizontal 1296x728
    (supports 2x2 binning)

    VGA 640x480 90 fps
    subsampling from 1280x960 to 648x484
    (supports 2x2 binning)

    QVGA 320x240 120 fps
    subsampling from 1280x960 to 324x242
    (supports 2x2 binning)

    So as you can see, modes 2, 4, 5, 6 are using subsamling method, (with just a tiny cropping) so FoV will be about the same as the mode 1 (full resolution).
    While mode 3 (1080p) is a RoI cropping thus only the middle portion of the image area is read. Basically, it becomes a crop sensor in this mode.
    This translates to smaller FoV.

    Post Reply