Where can I find hardware drivers?

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 1
    Joined: Sat Jul 02, 2016 3:39 pm

    Sat Jul 02, 2016 4:25 pm

    The easy question , what/where is hardware drivers ?

    I reinstall Win10 32bit and choose 'Traditional Chinese version', it runs OK but no WIFI, something wrong on Graphics and USB.
    I've read lots of message about drivers in this forum. the 'Intel Driver Update' , '2+32_X86_Drivers' etc.. All of them go wrong with me.

    Intel Driver Update said 'not found' after scan the LattePanda hardware.
    2+32_X86_Drivers got 'wrong hardware' error on Realtek WIFI and Graphic driver when load the INF file by pnputil program. (pnputil -i -a igdlh.inf , cmd command line interface by admin role). If I run 'Setup.exe' on PlatformInstaller directory (GUI interface), it still goes wrong and said can't install.

    Please let me know which IC/Chipset the Audio/WIFI/Graphic used ? hope I can find them back one by one.


    BTW, I'd reinstalled Win10 32bit English version before , and run 2+32_X86_Drivers. it also got lots of error messages ( I know the story about .inf.txt should change name to .inf) , and system became unstable and easy to hangon/halt . I'm sure it's the wrong driver make it unstable.

    Thanks again.

    User avatar
    Posts: 75
    Joined: Sun May 01, 2016 7:19 pm

    Wed Jul 13, 2016 3:53 am

    Moin Moin,
    I have written a little how to viewtopic.php?f=10&t=263 it is for the 64gb version but with some changes it should work for the 32gb too.
    Live long and prosper!

    User avatar
    Site Admin
    Posts: 2710
    Joined: Wed Jan 20, 2016 9:09 am

    Mon Aug 15, 2016 9:00 am

    a collection of resources are documented here

    Enjoy Tinkering with LattePanda ! :lol:

    Post Reply