[DEFECTIVE] LattePanda Alpha won’t turn on, LEDs only blink red

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 5
Joined: Mon Nov 05, 2018 8:18 pm

Mon Nov 05, 2018 8:29 pm

I recently got a LattePanda Alpha, and it has been working fine up until today. When I plug in the power supply, I just get a red blinking led (d13) instead of the usual blue and red (pwr/d13) sequence. Pressing the power button does nothing. Pressing reset does nothing. I tried the hard reset sequence outlined here on the troubleshooting forum, but it doesn’t seem to do anything either.

Can anyone tell me what the slow blinking red led means??

Any other help would also be appreciated. I hope my board isn’t dead :cry:

User avatar
Posts: 3
Joined: Wed Sep 26, 2018 12:23 pm

Fri Nov 09, 2018 7:25 am

Are you shure that you have a Lattepanda Alpha? As far as I know the Alpha doesn‘t have a power button (I have an Alpha and a „normal“ LP 4G64G which has both, power and reset button)

User avatar
Posts: 5
Joined: Mon Nov 05, 2018 8:18 pm

Sat Nov 10, 2018 6:50 pm

Yes, I’m positive that this is one of the new LattePanda Alpha models. I preordered and had to wait for months for it to arrive in the last few weeks.

I’m referring to the power button (circled in green) in this image: Image

User avatar
Posts: 5
Joined: Mon Nov 05, 2018 8:18 pm

Sun Nov 18, 2018 7:33 pm

Bummer.. If I can’t get this figured out in the next couple days, I’ll be sending my board back for RMA :(

User avatar
THW Mark
Posts: 11
Joined: Tue Jan 08, 2019 2:55 pm

Wed Mar 13, 2019 8:04 am

have you managed to find a solution? My board seems to have the same issue starting this morning.

I'm using the panda in titan case with a 256gb SSD for video editing and other stuff. Yesterday afternoon it turned itself off for no apparent reason. This morning when i plugged in the power again i noticed only a blue flashing light, no red light/boot sequence....

User avatar
Posts: 10
Joined: Mon Apr 25, 2016 8:14 pm

Tue Apr 23, 2019 7:58 pm

Same problem here, did you get a response regarding RMA?

Post Reply