Alpha won't turn on

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
User avatar
calpin
Site Admin
Posts: 22
Joined: Fri Apr 15, 2016 9:21 am

Thu Nov 29, 2018 3:18 am

Ok ,already provided to our engineer

User avatar
acua
Posts: 1
Joined: Thu Jan 17, 2019 10:00 am

Thu Jan 17, 2019 10:11 am

Same problem here. Spent ages researching for the best board for my product development. Sadly I didn’t come by this forum before I ordered mine and had it delivered halfway around the globe.

Has anyone made any progress on this?

User avatar
bluelux
Posts: 1
Joined: Tue Jan 29, 2019 2:18 pm

Tue Jan 29, 2019 2:34 pm

Me too, I have the same problem... How can I do?

Post Reply