Calling all iCube battery users!

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
john_mckale
Posts: 6
Joined: Fri Jan 25, 2019 12:12 am

Fri Mar 01, 2019 11:03 pm

So I have been experiencing the issue that alot of people have been experiencing with the USB C power supply where some or none of the leds flash (in my case I have just the blinking 6s blue power light) and no boot or response from the alpha.

I have tried alot of different combos to get it to boot and figured maybe powering it through one of the other options would work due to it possibly being stuck in the negotiation.

I ordered one of the iCube batteries from ali last week. Patiently waiting for it arrive to see if it does get me through this issue.

Has anyone been in the situation where the USB C option is no longer viable, but were able to bring it back to life by use thealternative battery or DC input?

Post Reply