Fail to power on.

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 5
Joined: Wed Nov 21, 2018 2:19 am

Wed Jun 19, 2019 1:28 am

I have had my Alpha 864 with windows activated for around 7 months.
This has been a great little workhorse, however a little over three weeks ago, it just stopped.

I have a 1TB SSD connected to the M.2 M-Keys slot which for the last 2 months contained the windows 10 OS.
Typically I do not turn off the Alpha except in the case of a power failure.
The Alpha has also been installed in a case that allows the fan to provide cooling, allow access to the connectors on the board and prevent accidental shorts by other loose components on my desk.
The BIOS setting have not been altered in the last 2 months (When i changed the boot device) and the thermal control has been set to maintain the CPU at the lowest temperature.
It has been powered by the supplied USB-C PD.

Last week on returning home from work, I noted it was powered down, pressing the power button did not turn it back on.

Testing has the following results:
The USB-C power supply is delivering 14.9V @ 0.04A.
None of the LED's are turning on at all.
I connected 12.0V-DC from a regulated power supply instead of the USB-C and noted a 0.016 amp current draw. Still the Alpha will not turn on.

With the Alpha orientated to that the CPU is on top and the USB-C is to the left, I started testing voltages on the round pads near the USB-C port and 12V power connector
when powered from the USB-C the middle pad of a group of 3 on the left side of the EJ898H USB-C power controller has 3.3V present, the other two pad have nothing.
When powered from the 12V DC all three pads are at 0V.
On the right side there is a pad with 3.3V when powered from either the USB-C or the 12V DC.

The external power switch connection also does not turn on the Alpha and has 0.5V across the terminal when powered by either the 12V DC or the USB-C.

The RTC Battery is testing at 3.1V
The 3.3V connections near the RTC battery are at 0.58V and the 5V is at 0.00V

Under the microscope I cannot see any visible signs of damage.

I suspect a component failure in the power control circuit, but without a schematic I am unable to proceed with any further investigations.

I have tried various reset methods suggested in the forum including the holding down of the Arduino reset with the power on button both with and without power connected, and the removal and reinsertion of the RTC battery for up to 24 hours.
None of the suggested fixes have worked.

Up until now, I found the Alpha to be a remarkable powerful PC
for both development work as well as some gaming,
I however have an amount of development work stored on the EMMC and would really like to get that data back along with getting the Alpha back up and running.

Is there any chance of obtaining the schematics so I can continue to diagnose and hopefully fix my Alpha.
Once repaired, I am happy to forward details of what failed for future reference.

This email has been sent to, however at this stage there has been no reply after 2 weeks.
I really do need the information stored on the emmc so would like to track down and repair the failed component.
I am really missing the little Alpha, it is incredible just how useful it is.
For those doubting its power, I run 3 monitors on this unit and program FPGA's with, mostly because I can :-)
It's only a failure when you stop trying.

User avatar
Posts: 5
Joined: Wed Nov 21, 2018 2:19 am

Wed Jun 19, 2019 4:42 am

Just as an addition, testing of the 5V pins on all the headers returns 0V, while all the 3.3V return 0.58V
Also, when the RTC battery is removed, a voltage of -1.52V exists on the +RTC terminal, then negative value of this is quite puzzling.
While out of the circuit, the RTC battery measured 3.1V but installed and with the USB connected the +RTC is 2.98V
It's only a failure when you stop trying.

User avatar
Posts: 754
Joined: Sat Oct 13, 2018 9:16 pm

Wed Jun 19, 2019 9:12 am

Have you tried no RTC battery in place then power on method?

User avatar
Posts: 5
Joined: Wed Nov 21, 2018 2:19 am

Fri Jun 21, 2019 6:27 am

Hello ccs_hello,

Yes I have tried a number of sequences with and without the RTC battery installed, still no luck.

It never occured to me to test what voltages were where with the unit powered off but power connected before it failed.
This kind of information may be helpful now :-)

I don't suppose you could measure the voltage across the external power button and the various power rails on the interface connectors with the Alpha powered off but power connected.

I suspect there should be 3.3V across the external power button and 5V on the Arduino power connections.
It's only a failure when you stop trying.

User avatar
Posts: 214
Joined: Mon Apr 18, 2016 4:30 am
Location: Germany, NRW

Sat Jun 22, 2019 8:29 am

My Alpha, mounted on the back of a 10.1-inch touch screen.
Power supply via my own 12V power supply, because the electronics of the LCD also needs 12V.
To make the connection compatible with the devices of our company, I had to use the large green connector.
(can not upload any pictures at this moment :( )

Behavior when applying the 12V, power LEDs red and blue next to the connector "SW
Step one:
blue : 1 short flash
red : starts with light-dark dimming, approx. 6 seconds long
Step 2:
blue : off
red : approx. 1 second off
Final state (Power-Off-State):
blue : 1 short flash every 4 seconds
red : dark on

Power consumption now : 85mA / 12V
Voltages :
Ardunio_5V : 5,0V
BIOS_5V : 5,0V
BIOS_3V3 : 3.3V
I2C_1V8 : 1,8V

Voltage via plug connector "SW" : 3.2V

I hope this will help you :)

User avatar
Posts: 5
Joined: Wed Nov 21, 2018 2:19 am

Sun Jun 23, 2019 3:27 am

Thanks for that info Lutz,

Well, I did not get the 5V at all,
The 3.3V on the bios connections are currently at 0.57 volts
The plug connector "SW" is at 0.50 volts
and the 1.8 on the I2C is at 0V
current load via the 12V input connector is 15mA
PIC000.jpg (448.13 KiB) Viewed 3015 times
Based on the attached image, I get 3.3V at the test pad near the PD controller chip.
However the other side of a resistor near this chip I get 0.57V.
This is starting to look like a short on the 3.3V power rail with current being limited by this resistor.
as a result, the rest of the board is unable to power up to the standby condition with the voltages listed by Lutz.
That resistor measures 523 ohms, so i have a current through it of around 5.2 mA and dissipating 14.3 mW of power.
PIC003.jpg (349.58 KiB) Viewed 3015 times
I started to probe around the power button.
I wasn't able to find any voltage across the button, however the resistance was open normally and went to 0 ohm when pressed.

At this point a schematic would be very useful.

I am of the opinion that I am looking for a shorted component on the 3.3V rail, this is a multi-layer board, at least 2 internal layers, hope is not an internal short.

Any help from LattePanda would be appreciated.
It's only a failure when you stop trying.

Post Reply