USB Boot Problem

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 25
Joined: Sun Sep 04, 2016 7:27 pm

Sun Jun 30, 2019 5:48 pm

Firstly, why is this page still blank: ... _software/
I dont want to use the stock windows 10 image, it has tonnes of the reporting options enabled by default and seems to have some dodgy background services, I want to refresh my OS with a completely stock image installed on nvme. However, no matter what I try, the LattePanda Delta will not see any USB storage as a valid boot device, it works in OS and the same USB storage works fine on other machines (I fresh installed windows on another PC with the same media today), I just cannot get the lattepanda to see it, am I missing something?

User avatar
Posts: 25
Joined: Sun Sep 04, 2016 7:27 pm

Sat Sep 28, 2019 7:53 pm

No answers at all? How useless is support here. Why can I *still* not obtain drivers for a product that has been out for quite some time? I have already proven via wireshark and malwarebytes that there is malware in the lattepanda factory image. I do not want to use the factory image any longer, but I cannot obtain drivers for a fresh install and the delta will not boot from USB.

User avatar
Posts: 745
Joined: Sat Oct 13, 2018 9:16 pm

Sat Sep 28, 2019 8:49 pm

Not sure the Win10 build with necessary/appropriate driver detailed steps...
However one thing for sure : please use "Rufus" to build the USB boot image.

User avatar
Site Admin
Posts: 2760
Joined: Wed Jan 20, 2016 9:09 am

Sun Sep 29, 2019 9:46 am

Hi SixSixSevenSeven, we have updated some content in the Driver page. We recommand Intel Driver Assistant to install drivers if you use your own Windows system.
Enjoy Tinkering with LattePanda ! :lol:

Post Reply