LattePanda Alpha 864 No Power

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 1
Joined: Thu Aug 22, 2019 10:48 pm

Mon Sep 02, 2019 8:10 pm

I've had been tinkering around with this for about a week.. I've been using the supplied power supply and left it on over night, now it is not powering up. No LED comes on, I've tried the 20 sec power+reset method and nothing. Any suggestions or tricks? or should I RMA it?


User avatar
Posts: 754
Joined: Sat Oct 13, 2018 9:16 pm

Tue Sep 03, 2019 12:49 am


Please switch forum to Alpha/Delta sub-forum to see the possible solutions/troubleshooting procedures.
You are in the wrong branch of the forums and the procedure you tried to use is not intended for Alpha/Delta.

User avatar
Posts: 214
Joined: Mon Apr 18, 2016 4:30 am
Location: Germany, NRW

Tue Sep 03, 2019 4:05 am

Topic moved

Post Reply