Bootable USB not in bios boot menu

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 3
Joined: Wed Dec 11, 2019 2:33 pm

Wed Dec 18, 2019 8:29 am

I just bought a lattepanda s70ocr200-cc55f and I would like to install a linux dist on it. My problem right now is that I cant boot on the usb stick. It is not visible in the bios boot menu when pressing F7. I have tried different sticks formatted to FAT32 and the command that I use to write the image is: sudo dd if=/home/youriso of=/dev/sdxx bs=4M status=progress oflag=nocache,sync

I have tried different distros but the same issue occurs and I cant boot on the stick. As far as I can see the tutorial on ... u-1604-lts
is not valid for my model. I have read and tried several tips found on this forum but it does not work.

Could someone please guide me on how to get the bootable stick to display as an alternative in bios.
What distro is most likely to work?

Thank you

User avatar
Site Admin
Posts: 2662
Joined: Wed Jan 20, 2016 9:09 am

Wed Dec 18, 2019 9:37 am

Hi tubbs, the tutorial is valid for your model. Please install Linux aboording to the tutorial.
Enjoy Tinkering with LattePanda ! :lol:

User avatar
Posts: 3
Joined: Wed Dec 11, 2019 2:33 pm

Wed Dec 18, 2019 2:33 pm

I have managed to install the bios and that part i is working. I have written the ubuntu image to the usb-stick FAT32.
I insert the ubuntu usb-image-stick into the lattepanda but it boots directly in to windows. If I press F7 to get the boot-menu it is like before, no option to select the usb bootable stick and the same goes for if I enter the bios setup there is no option to select the stick. I have tried all usb ports and two different usb disks. Any suggestions?


User avatar
Posts: 9
Joined: Sun Nov 24, 2019 4:10 pm

Fri Dec 20, 2019 5:46 am

Hello tubbs,

Have you tried another USB flash drive?
I am asking because I have a particular flash drive which I was never able to boot from. I later found that the controller of that drive is known to have that issue (SMI branded controller).

User avatar
Posts: 3
Joined: Wed Dec 11, 2019 2:33 pm

Fri Dec 20, 2019 7:49 am

In case someone else would bump in to the sam problem.

I was using dd on ubuntu linux to write the lattepanda cherrytrail iso if=/home/youriso of=/dev/sdxx bs=4M status=progress oflag=nocache,sync USING DD IS NOT WORKING

Instead i wrote the image using Rufus on a windows machine. After the the writing was done Rufus asked if the image should be dd or iso. I selected iso and now it is working. I don't know the difference but it's working.

Thanks for all guidance.

Post Reply