[DEFECTIVE] RMA - Lattepanda Delta died after 4-5 seconds

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 1
Joined: Wed Mar 04, 2020 8:45 am
Location: Germany

Thu Mar 05, 2020 9:27 am


two days ago my Lattepanda Delta from DFRobot arrived and I just started to assemble it with titan case and the touchscreen.
Plugged in the USB-C cable, saw the leds blinking and hold the power button for three seconds. Bootscreen from Windows 10 came up and after 4-5 seconds while booting, it shut off and everything gone black. No screen ouput, no leds anymore.
Tested every tips and tricks from the forum here, like 12V DC, another USB-C plug, hard reset with 20 seconds, but can't get it working again. No sign of life.

Is there anything I can do further? If not, please RMA as soon as possible.

Thanks in advance.
Best regards,

User avatar
Site Admin
Posts: 2771
Joined: Wed Jan 20, 2016 9:09 am

Fri Mar 06, 2020 8:51 am

Hi Alex, sorry for this, pls contact our techsupport@lattepanda.com for help. they will send you RMA guide.
Enjoy Tinkering with LattePanda ! :lol:

Post Reply