Freezes over longtime usage

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
M100FAT
Posts: 4
Joined: Mon Dec 09, 2019 12:51 pm

Wed Jul 08, 2020 12:20 pm

Currently we are using several LattePanda Alpha's to power some of our presentation products but we cannot get the stability we need from them. We have been carefully monitoring CPU usage, memory usage and CPU temperature but none of them seem to be the problem.

The problem:
When running LattePanda's for a long amount of time, after a minimum of two weeks (or so it would seem until now) they will start having complete freezes. Windows will freeze and while some background processes seem to still be active there is no getting the panda out of this state. The system is also not writing any logs or events in the event viewer during this time. The only way to fix this state is by holding the powerbutton/forcing a restart/shutdown.

At first the panda's would only reset at night, but never have a full shutdown. We thought this could be a problem so we set up a full shutdown for a few hours at night. This also did not fix the problem. We started using the four pin DC connector as we figured we'd eliminate the possibility of an insufficiently powerful power supply. We also tried forcing programs to write procdumps on crash but they also don't happen when it gets frozen, suggesting it isn't a software issue, or the freeze is so complete that no logs or dumps can be written.

Since the panda's were running relatively hot, 70 -80 degrees celsius, we've also switched to a radiator cooler case with external fan, this has reduced the temperature to 55 - 65 degrees celsius. CPU load varies between 35% and 60% with some spikes to 90% but these are nearly always caused by windows processes or updates. GPU chip load hovers around 60% usage.

The panda's are running a Unity3D application with Leap software and a Leap Motion attached. An extra lattepanda we have for testing purposes has also crashed without the Leap attached.
Using Unity 2019.1.7.f1

Does anyone recognize this issue?

We are running the auto-power-on updated Alpha m3-7y30 bios.

User avatar
calpin
Site Admin
Posts: 46
Joined: Fri Apr 15, 2016 9:21 am

Tue Aug 11, 2020 3:26 am

Hi there,
What do you mean "freezes" can you help to share a video about that
when you notice it freeze, is the screen still work?
About "reset at night", any chance it plan to update at night?
The events viewer will not update when you open it. Try re-open the viewer.
But that's strange because even the system keep running without any operation it will also update a event about the running time every day.

User avatar
M100FAT
Posts: 4
Joined: Mon Dec 09, 2019 12:51 pm

Mon Aug 24, 2020 7:37 am

Hi thanks for your reply, getting a video of it will be hard since it isn't very predictable when it happens.
When it's frozen the screen does still work and will not go on standby but nothing changes on screen.
If by update you mean windows update we already do update it at night.
At the point of a freeze I can't reopen the event viewer unfortunately.
Yes it's very strange, it should indeed still post some events, but it doesn't if its frozen. This to me suggests that the system is frozen on a (close to) hardware level.

User avatar
ccs_hello
Posts: 623
Joined: Sat Oct 13, 2018 9:16 pm

Mon Aug 24, 2020 1:21 pm

Intermittent issues are hard nut to crack.
If you suspect its a hardware related issue, first thing to do is to change to a high quality power supply.
If suspect a software related, try to run a routine watchdog program to frequently send a message to a port to ensure the OS is running (while a specific application is not.)

Post Reply